Opened 8 years ago

Closed 8 years ago

#50 closed defect (fixed)

Moving massive amounts of files via drap&drop eventually fails

Reported by: gyoung Owned by: stevenhl
Priority: major Milestone: Release_3.5.9
Component: fm/2 base Version: 3.05
Keywords: hangs Cc: strrom@…

Description

When moving massive amounts of files from one area to another,
eventually, (100% of the time), it will stop doing the job. Normally I
will highlight the files that I want moved, dragndrop them on the
directory I want them to and select "Move" from the resulting popup
window. Eventually, nothing happens after I click the move button with
no resulting error code.
I must add that while this method no longer works I CAN highlight
all my files, click the "Move" button in the menu bar, select the
necessary drive/dir in the dialog window and move that way just fine
but, that quickly gets tiresome

Change History (6)

comment:1 Changed 8 years ago by gyoung

Since fm/2 is not hung, it is more likely the problem is leaking resources
that the kernel can't recover on a normal app shutdown. This can happen
for GUI resources. They are created by the app but can end up owned by PM
and PM is supposed to release these resources when the app exits. I've
been told there are cases where this does not occur. Since there's no way
to restart PM these resources will not be recovered without a reboot.

comment:2 Changed 8 years ago by gyoung

  • Cc strrom@… added

comment:3 Changed 8 years ago by stevenhl

  • Owner StevenHL deleted

comment:4 Changed 8 years ago by stevenhl

  • Keywords hangs added
  • Milestone set to Release_3.5.9
  • Owner set to stevenhl
  • Status changed from new to assigned
  • Version set to 3.05

comment:5 Changed 8 years ago by guest

I wasn't able to produce this failure. What I did notice is that if "immediate updates" is NOT checked in the notebook setup, it is hard to tell if FM/2 is doing anything. The container doesn't start populating with files. The CPU shows very little activity. However, if I watch my harddrive light, I can tell the move process is still being carried out. Once my harddrive light is out, I do a recan and the files have been moved to the desire partition.

David

comment:6 Changed 8 years ago by gyoung

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.