Opened 12 years ago

Closed 11 years ago

#154 closed defect (fixed)

Trap caused by FM/2 being on a full disk

Reported by: gyoung Owned by: gyoung
Priority: major Milestone: Release_3.13
Component: fm/2 base Version:
Keywords: Cc:

Description

The actual cause was the disk FM/2 was on was full. I lost filters.dat as a result. While a failure of some kind would be expected in this case it would be nice if it failed gracefully. Should I file a bug or is this just the way it is in a situation like this. The failure was in Module: D:\WATCOM/lib386/os2\clib3r.lib(mem) 0002:00043bf0 MemFree

according to the map file. Thanks

Gregg

08-24-2007 15:15:30 SYS3175 PID 04fa TID 0009 Slot 007d E:\FM2\FM3.EXE c0000005 1d323c7e P1=00000002 P2=00000008 P3=XXXXXXXX P4=XXXXXXXX EAX=00000000 EBX=00440000 ECX=0044495c EDX=00000000 ESI=00440000 EDI=00000000 DS=0053 DSACC=f0f3 DSLIM=ffffffff ES=0053 ESACC=f0f3 ESLIM=ffffffff FS=150b FSACC=00f3 FSLIM=00000030 GS=0000 GSACC= GSLIM= CS:EIP=005b:1d323c7e CSACC=f0df CSLIM=ffffffff SS:ESP=0053:02dde58c SSACC=f0f3 SSLIM=ffffffff EBP=02dde60c FLG=00012206

FM3DLL.DLL 0002:00043c7e

Change History (8)

comment:1 Changed 12 years ago by gyoung

Yes. We will need a trap dump to find the code we need to fix, but we can use spacehog to fill a volume easily enough. I assume you had recently edited the commands or it would not have been open for writing. It so, make sure to note this.

Also note filter.dat was probably open because I had just changed the filter selection in the collector.

comment:2 Changed 12 years ago by gyoung

  • Milestone Release_3.8 deleted
  • Version 3.08 deleted

comment:3 Changed 12 years ago by gyoung

  • Milestone set to Release_3.9

comment:4 Changed 12 years ago by gyoung

  • Milestone changed from Release_3.9 to Release_3.10

comment:5 Changed 12 years ago by stevenhl

  • Owner set to stevenhl

comment:6 Changed 11 years ago by stevenhl

  • Milestone changed from Release_3.12 to Release_3.13

comment:7 Changed 11 years ago by gyoung

  • Owner changed from stevenhl to gyoung
  • Status changed from new to assigned

comment:8 Changed 11 years ago by gyoung

  • Resolution set to fixed
  • Status changed from assigned to closed

CS 1118

Note: See TracTickets for help on using tickets.