Opened 18 months ago

Last modified 18 months ago

#73 new defect

SVN rev 354: formatting of FAT16 media via GUI (PMFORMAT) hangs

Reported by: erdmann Owned by:
Priority: major Milestone: Future
Component: IFS Version:
Severity: medium Keywords:
Cc:

Description

As a test, tried to format a VFDISK inserted virtual floppy: 1) "format x:" from a commandline worked 2) Trying to format via the GUI /WPS by selecting "Format" from the context menu of the virtual floppy hung. It did not matter if I selected "Quick Format" or not

Change History (3)

comment:1 Changed 18 months ago by erdmann

If I use the builtin FAT16/FAT12 file system support, formatting works from the commandline as well as from the GUI.

comment:2 Changed 18 months ago by valerius

I see pmformat.exe starting and immediately disappearing, not hanging (if start "FORMAT..." from drive context menu). Anyway, PMFORMAT does not support "FAT32" as a floppy filesystem, so this may be because of this.

PS: I have an idea, to rename FAT32.IFS to UNIFAT.IFS with FS_NAME="UNIFAT" and use it as a library. And make a special IFS stub, which will have FS_NAME="FAT"/"FAT32"/"exFAT" passed to it as a command line parameter. It will determine addresses of UNIFAT.IFS entry points on init with DosQueryProcAddr?, and its entry points will be just UNIFAT.IFS entry points wrappers. FS_MOUNT of a stub IFS will only mount it's own filesystem and reject other file systems. UNIFAT.IFS FS_MOUNT will reject to mount everything. So, fat32.ifs will show correct file system.

comment:3 Changed 18 months ago by valerius

BTW, it seems that changing FAT drives' filesystem from FAT to FAT32, or vice versa causes Floppy icon in Drives object hang the WPS when right-clicking by mouse. Recreating the Drives object by SysDestroyobject/SysCreateObject? with REXX partially helps, but right-clicking physical floppy icon still hangs the WPS. Vitrual floppy (VFDISK) is ok. So, it seems that WPS assumes A: and B: floppies to be FAT only, otherwise it hands the system. VFDISK floppy is assumed to be other type of drive (even the icon is not floppy, but like a memory card, or integrated circuit). Right-clicking the virtual floppy doesn't hang the system. So, this seems to be a WPS fault. But right-clicking the virtual floppy with chosing "Format..." menu item causes PMFORMAT to blink and disappear. Right-clicking other FAT drive managed by fat32.ifs causes PMFORMAT to start ok, but it won't format anything, just does nothing. This seems to be a PMFORMAT problem. (Trying to start "FORMAT x: /fs:fat" parameter works the same on a IBM FAT and on FAT32.IFS,so I wonder what could be the difference. The only difference is that the original drive is reported as "FAT32".) PMCHKDSK on any drive also blinks and disappears. Why it should be?

Last edited 18 months ago by valerius (previous) (diff)
Note: See TracTickets for help on using tickets.