Opened 2 years ago

Closed 20 months ago

#62 closed defect (fixed)

CACHEF32.EXE no longer respects the /S parameter

Reported by: ataylor Owned by:
Priority: Feedback Pending Milestone: Future
Component: IFS Version:
Severity: medium Keywords:
Cc:

Description

Using build 0.10.r288. CACHEF32.EXE displays the message: FAT32: Unicode translate table for codepage xxx loaded. even when the /S (silent) switch is specified.

This is a regression to a long-running bug which was present in FAT32 builds 0.9.12 and earlier. This was fixed in 0.9.13 and the /S switch functioned as expected in that and later versions until the appearance of this regression.

Change History (4)

comment:1 Changed 2 years ago by valerius

L:\src\fat32\trunk\src\ufat32>cachef32 /s
CACHEF32 is already running.
Current priority is Regular.
LAZY WRITING is NOT active!


Read-Ahead sector count for drive E: is 128.
Read-Ahead sector count for drive G: is 32.
Read-Ahead sector count for drive H: is 128.
Read-Ahead sector count for drive J: is 32.
Read-Ahead sector count for drive K: is 128.
Read-Ahead sector count for drive Q: is 4.
Read-Ahead sector count for drive W: is 128.
Read-Ahead sector count for drive X: is 2.
Read-Ahead sector count for drive Z: is 16.

FAT32.IFS has currently 15 GDT segments allocated.

I don't see the message

FAT32 cache helper version 0.10.r302.
FAT32: Unicode translate table for CP 866 loaded.

But I see it without /s specified. Though, other messages are present. But I had complaints about behaviour of the /s option from Martin Iturbide -- he likes these options very much, so I fixed it for him. Probably, you're using a too old version -- please, try the latest one.

PS: Unicode translate table loadin is moved to uunifat.dll. The "regression" was because I did not properly passed the fSilent flag to correspondin routine. This was fixed in the r295.

Last edited 2 years ago by valerius (previous) (diff)

comment:2 Changed 2 years ago by valerius

  • Priority changed from minor to Feedback Pending

comment:3 Changed 20 months ago by valerius

No feedback, closing.

comment:4 Changed 20 months ago by valerius

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.