#34 closed defect (fixed)

COPY (or XCOPY) /V results in SYS0031 (Device not functioning) or end of process

Reported by: lewisr Owned by:
Priority: Feedback Pending Milestone: Future
Component: IFS Version:
Severity: high Keywords:
Cc:

Description

The following is observed with r175 (n: is the FAT32-formatted USB stick - primary partition):

[C:\]copy n:\* c:\SANDISK16GB /v
n:\file1.dat
SYS0031: A device attached to the system is not functioning.

Going the other direction, no error is observed, but process stops after first file.

The same actions work as expected under HPFS (tested against another USB stick with a similar single partition, same USB stack & settings).

CONFIG.SYS has:

IFS=C:\OS2\BOOT\FAT32.IFS /h /ac:h

Change History (4)

comment:1 Changed 22 months ago by valerius

I cannot reproduce this on my machine. Most probably, this is an error with ReadSector? failing to read sectors:

P:576 T:3d D:0 T:59:62 ERROR: ReadSector of sector 32 (0 sectors) failed, rc =
31
P:576 T:3d D:0 T:59:69 GetNextCluster for 4 failed

which also returns error 31. The error is not yet fixed and is a side effect of a bug which appeared after I added support for 64 KB sectors. ReadSector? fails to read sectors, and returns 0 sectors. It blocks execution for some time, then after some waiting, FC/2 exits (if copying was done by it).

If you'll encounter this again, please look into f32mon.exe output, to see, if it is ReadSectors? failing (like above).

comment:2 Changed 22 months ago by valerius

I cannot repeat it myself, and suspect that it is a sector read error. So, changing the status to "Feedback pending".

comment:3 Changed 22 months ago by valerius

  • Priority changed from major to Feedback Pending

comment:4 Changed 22 months ago by lewisr

  • Resolution set to fixed
  • Status changed from new to closed

I can no longer reproduce this with any FAT32-formatted media.

Note: See TracTickets for help on using tickets.