Opened 5 years ago

Last modified 4 years ago

#8 new defect

Print from CUPS to CUPS

Reported by: David McKenna Owned by: bart
Priority: major Milestone:
Component: Portdriver Version:
Severity: highest Keywords:
Cc: ataylor, David+McKenna

Description

Not sure if this is a bug or configuration issue...

I have a printer attached to a CUPS 1.4.8 server (HP DeskJet? 990C with HPLIP) on eCS 2.1 that works well. I can print from remote eCS clients to the server using a CUPS output port on the printer object.

Now I need to have CUPS installed locally on the clients (for QT and Java apps). I need to be able to print to the local CUPS and have that sent to the CUPS running on the server with the printer. I have tried setting up the CUPS printer on the clients using the ipp:// backend, but trying to print the test page just hangs 'processing page 1' forever, and no print job gets to the server. Trying the http:// backend always results in 'http backend failed' messages.

I also tried using Alex Taylors 'CupsWiz?' program (in eCS 2.2 beta) on a client to install the printer, and after selecting my printer from the list offered, the program hangs 'Looking for connected printers. Please wait...'. Then a VX-REXX window appears that says: 'Password for unknown on 192.168.0.2?' (the CUPS server with the printer). There is no password (that I know of) so this is a bit baffling. CUPSWIZ is hung and must be killed.

Change History (7)

comment:1 Changed 5 years ago by ataylor

|'Password for unknown on 192.168.0.2?'

<sigh> Unfortunately the CUPS commands stupidly don't seem to have any password argument, so I think that means they will always block on asking for a password if the server is configured to require one.

The real question is why you got a password prompt in the first place (and only this once?). AFAIK we don't support password configuration on CUPS for OS/2 (as it depends on the Unix password system which we don't have), so I'm rather surprised you saw this.

Unfortunately the CUPS command line interface seems to be full of irritating little traps like this. I try to add workarounds as I find them but it's a slow, painstaking process (and largely trial-and-error, too).

Try running the commands manually (from a command prompt) to see where this prompt actually shows up.

There are two commands that get run during this phase: \cups\lib\cups\backend\snmp.exe and \cups\sbin\lpinfo.exe -v

I'm wondering which of the two produced this password prompt...

comment:2 Changed 5 years ago by ataylor

Actually, I think I _may_ have an inkling what happened. You need to run the lp*.exe commands *from the CUPS drive*, not relative-pathed. Failing to do that does sometimes appear to cause this password prompt under some circumstances (probably due to it looking for the configuration information via relative path on the same drive).

If that's the cause, then the next release of CUPSWIZ should have a fix...

comment:3 Changed 4 years ago by ataylor

  • Severity set to highest

Please try the latest CUPS 1.4.8-3 and CUPSGUI WPI installers from NetLabs?.

The CUPS package replaces IPP backend to fix some problems. The CUPSGUI package should have logic to avoid this password prompt issue (at least under most circumstances).

comment:4 Changed 4 years ago by ataylor

  • Cc ataylor David McKenna added

comment:5 Changed 4 years ago by ataylor

  • Cc David+McKenna added; David McKenna removed

comment:6 Changed 4 years ago by David McKenna

Sorry for the very late reply....

This new CUPS and CUPSWIZ you recommend does solve the problem I indicated with CUPSWIZ and the password prompt. I can now create a printer using CUPSWIZ.

However, I still cannot connect to my CUPS server from a client thru the CUPS interface (both server and client using the same CUPS package you recommend). On the server I have CUPS set to 'share printers' and 'printing from internet'. On the client, if I open the CUPS web interface, go to 'Administration', then 'find new printers', no printers are found. After doing this there is always a new line in the error log on the client:

E [02/Feb/2014:10:53:30 +0500] [cups-deviced] PID 234 (http) stopped with status 8!

comment:7 Changed 4 years ago by David McKenna

Manually installing the printer using 'ipp://192.168.0.2/printers/HPeCUPS' as connection does work now (it was the 'printers' part that eluded me). This ticket can be closed...

Note: See TracTickets for help on using tickets.