Opened 11 months ago

Last modified 9 months ago

#27 new defect

cups-filters 1.13.3-2 print only single copies from pmview, ignoring specified 'number of copies'

Reported by: gerry Owned by:
Priority: Feedback Pending Milestone:
Component: cups Version: 2.0
Severity: medium Keywords:
Cc:

Description

about 2 weeks ago, anpm applied updates to cups filters, to version 1.13.3-2, since when pmview has been unable to print multiple copies

Attachments (1)

error_log (96.8 KB) - added by gerry 10 months ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 10 months ago by losepete

Looks like this problem is "cups-rpm" related rather than ecups and should be reported to the rpm people at http://trac.netlabs.org/ports/

comment:2 Changed 10 months ago by diver

  • Priority changed from major to Feedback Pending

does the copy switch work when printing from other applications? Or does multiple copies not work at all now. Which cups-filters did you have before?

comment:3 Changed 10 months ago by gerry

cups filters previously were at 1.8.2-5 (my laptop is still at that level with pmview printing multiple copies)

pmview does seem to be the only app that works that way; mesa/2, describe and lucide all create multiple print jobs for multiple copies. openoffice does create just one job, but the page-order possibilities are so complex that I suspect it builds a composite print stream.

the latest cups updates (2.1.3-10 and 1.13.3-2) still exhibit the problem.

comment:4 Changed 10 months ago by diver

please do the following:

  1. end cupsd
  2. change LogLevel? from warn to debug2 in x:\etc\cups\cupsd.conf
  3. delete error_log in x:\var\log\cups
  4. start cupsd
  5. print 1 file from pmview with multiple copies
  6. end cupsd
  7. attach the error_log

x:\ is where your unixroot env var points to. most probably to the boot drive

Last edited 10 months ago by diver (previous) (diff)

Changed 10 months ago by gerry

comment:5 Changed 10 months ago by gerry

hopefully done as requested, although dementia must be setting in as I cannot remember how to kill a deamon ..... fortunately there are other ways .....

comment:6 Changed 10 months ago by diver

probably there is a error_log.bak as well. Please provide that also.

btw I tried to reproduce it and here it prints 2 copies from pmview when 2 copies are requested. but I use a later cups-filters rpm from netlabs-exp

if you have netlabs exp repo enabled please update to the latest cups-filters. if you don't have it enabled please do so in anpm and update to latest cups-filters.

comment:7 Changed 10 months ago by gerry

thanks ....

there is an error_log.O but it is too large to upload (>1M)

netlabs-exp is in the repos.d directory, but anpm does not show it as an available repository

comment:8 Changed 10 months ago by diver

I'm not a ANPM user at all. So I have no idea how to work with that. The good thing is, I found another user with the same copy issue. So I might find a solution soon. Stay tuned.

comment:9 Changed 10 months ago by diver

could you do some tests?

  1. hold the printer queue
  2. print something from pmview with several copies
  3. look at the properties of the print job

how many copies do you see there?

comment:10 Changed 10 months ago by gerry

I don't see a 'copies' heading in the job properties, only name, user, size, pages, state.

'pages' differs between the two versions:

  • the laptop with 1.8.2-5 shows '1'
  • desktop with 1.13.3-2 shows 'unknown'

comment:11 Changed 10 months ago by diver

the printing job properties shows the number of copies. I mean the properties from the OS/2 printing queue not within cups.

comment:12 Changed 10 months ago by gerry

os/2 printer queue shows number of copies = 1

comment:13 Changed 10 months ago by diver

and as long as this is 1, cups will not print more than 1 copy. Why this should have changed with the update of cups-filters is a mystery to me. As cups is invoked from the port driver with those info. So I doubt I can do anything about that.

comment:14 Changed 10 months ago by gerry

hmmmm ... not sure about that .... it is 1 on both systems, laptop and desktop, anfd the laptop with the old lrvr of cups-filters, prints 2 copies

comment:15 Changed 10 months ago by diver

as I have no idea how this should work at all with 1 copy, I can't help you more. Sorry. Eventually Alex Taylor has some ideas, as he know the printing system (before cups kicks in) a lot better than me. But for that it might be easier to open a report at ArcaNoae?.

comment:16 Changed 9 months ago by diver

Just for the record. I found another user with exact this issue. This user uses a Postscript printer direct attached (no cups involved). So I really wonder if the cuase is something else and not cups. We try to figure it out with the above mentioned user. But it may take some days.

Note: See TracTickets for help on using tickets.