Opened 3 years ago

Closed 4 months ago

#24 closed defect (fixed)

libusb crashes system

Reported by: batchheizer Owned by:
Priority: Feedback Pending Milestone:
Component: cups Version:
Severity: highest Keywords: USB libUSB HP 1606
Cc:

Description

On my new eCS 2.2 b 2 I will get my HP_LaserJet_Professional_P1606dn working. Via network are problems - so I tried USB.

  1. Printer not connected:

DEBUG: list_devices DEBUG: usb_find_busses=1 DEBUG: usb_find_devices=2

  1. Printer connected to a USB 2-Port.

DEBUG: list_devices DEBUG: usb_find_busses=1 DEBUG: usb_find_devices=3 direct usb://Unknown/(null)?serial=000000000QQ07LCPPR1a "Unknown" "Unknown" "Φ"

""

If I click Add Printer in "CUPS Administration (Local)" with connected USB-Printer the system crashes (black screen, reboot). Any idea?

Change History (3)

comment:1 Changed 3 years ago by batchheizer

On my other System (ecs2.1):

DEBUG: list_devices
DEBUG: usb_find_busses=1
DEBUG: usb_find_devices=2
direct usb://HP/HP%20LaserJet%20Professional%20P1606dn "HP LaserJet Professional
 P1606dn" "HP LaserJet Professional P1606dn" "MFG:Hewlett-Packard;MDL:HP LaserJe
t Professional P1606dn;CMD:ZJS,PJL,ACL,HTTP,PCL;CLS:PRINTER;DES:HP LaserJet Prof
essional P1606dn;FWVER:20091029;" ""

That seems to be normal.

comment:2 Changed 5 months ago by diver

  • Priority changed from major to Feedback Pending

is this still true with latest cups and latest libusb?

comment:3 Changed 4 months ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

no feedback, so closing the issue. If you still have cups issues please open a ticket at https://github.com/bitwiseworks/cups-os2/issues

Note: See TracTickets for help on using tickets.