Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#4 closed defect (fixed)

Possible geometry bug ?!

Reported by: ecsnl Owned by: somebody
Priority: major Milestone:
Component: driver Version: 1.12
Keywords: Cc:

Description

The following scenario we have:

A machine that runs in legacy and AHCI mode in the BIOS.
We switch the machine to legacy mode and run with Danis506.add version 1.8.9.

On a 1 .5. TB driver I installed boot manager first. Then I create a primary 200000 MB partition. Then the rest of the drive gets allocated by a logical partition of about 1.3 TB. Both partitions are added to the IBM boot manager. I can format the volumes and they are also listed in the installer as being volumes to which eComStation
can be installed.

Then when I switch the BIOS to AHCI mode and load OS2AHCI.ADD driver (version 1.12) everything seems to work just fine!

But when I get to the installer page of eCS 2.1 I get the message no instable volumes where found and that the disc manager will be started (minilvm).

In the table where it says "notes" (the last column to the right in minlvm) it normaly mentions "Bootable " if a volume is added to the boot manager. Now with the AHCI driver loaded does "bootable" flags are gone. If I again load the system in legacy mode and with the DANIS506.ADD driver the bootable flags are displayed again in minilvm.

LVM does not give any error message when its get started. Attached is danis506.txt which is the output of lvm /startlog:. And OS2AHCI.txt which was created with the OS2AHCI.ADD loaded.

So it seems the LVM code is not able to read a portion of the disc. I presume the flags that tell bootmanager what partitions are stored in the bootmanager partition which is at the beginning of the disc.
Is this some kind of geometry problem ?

Attachments (5)

IBM1S506.TXT (117.0 KB) - added by ecsnl 8 years ago.
OS2AHCI.TXT (115.1 KB) - added by ecsnl 8 years ago.
DFS_AHCI.TXT (9.7 KB) - added by ecsnl 8 years ago.
DFS_AHCI.2.TXT (9.7 KB) - added by ecsnl 8 years ago.
DFSDANIS.TXT (7.5 KB) - added by ecsnl 8 years ago.

Download all attachments as: .zip

Change History (15)

Changed 8 years ago by ecsnl

comment:1 Changed 8 years ago by ecsnl

Oke made a typo in the file. IBM1S506.TXT=DANIS506.TXT

Changed 8 years ago by ecsnl

comment:2 Changed 8 years ago by ecsnl

When the system is switched in AHCI mode the bootmanager is started by the BIOS and I can select the volumes from the disc. So I guess that indicates the BIOS is not using a different disc geometry in AHCI mode.

comment:3 Changed 8 years ago by ecsnl

Well after having looked with Steve at the logs it might be an LVM wrapper issue ?
Comment welcome of course.
What we did is grabbed Graphical File Compare and via the command line loaded:

gfc.exe ibm1s506.txt os2ahci.txt

It seems the geometry is identical reported by LVM! Check the two logs.

What we see is line 326 from ibm1s506.txt that is missing in os2ahci.txt.
See line 326.

Compare line 2988 and down. See the difference between ibm1s506.txt and os2ahci.txt.
The whole boot manager stuff is different.

Interesting is that the LVM wrapper, wraps some bootmanager calls and this is effected.
I will leave this to Markus and Alex to look at this.

comment:4 Changed 8 years ago by markus.thi

I haven't had the time to look at the logs thoroughly, yet. I'll check it out tonight or tomorrow.

We should have a 1.5TB drive by tomorrow afternoon and will try to reproduce and investigate the issue then.

comment:5 Changed 8 years ago by ecsnl

Oke we have taken out our LVM wrapper from Alex and used the LVM.DLL from IBM directly.
It still happens, so it seems to be something in the os2ahci.add.

comment:6 Changed 8 years ago by ecsnl

Oke booted from eCS 2.1 CD 1. I ran dfsee for OS/2 with the DANIS506.ADD driver and with OS2AHCI.ADD driver loaded. The result are the 2 log files.

dfs_ahci.txt
dfsdanis.txt

Compare the two:
Daniela driver:

Geometry D1 from : LVM info (DLAT) sector at 0xfe
L-Geo Disk 1 Cyl : 45063 H:255 S:255 Bps:512 Size : 0xAEA7A207 = 1430772 MiB
BIOS Int13 limit : 1024, I13X support needed beyond :32512.5 MiB

AHCI driver:
Geometry D1 from : MBR table, matches for H:3 S:3
Disk 1 forcing : cylinders from 45063 to 182398
Disk 1 forcing : sectors from 255 to 63

L-Geo Disk 1 Cyl :182398 H:255 S:63 Bps:512 Size : 0xAEA7AAFE = 1430773 MiB
S-Geo Disk 1 Cyl : 45063 H:255 S:255 Bps:512 Size : 0xAEA7A207 = 1430772 MiB
BIOS Int13 limit : 1024, I13X support needed beyond : 8032.5 MiB
MBR crc 054b4eb9 : 0x0c8ca699 = DFSee generic MBR, English messages, I13X

Disc 2: Daniela:

P-Geo Disk 2 Cyl : 16383 H: 16 S:63 Bps:512 Size : 0x1D1C5970 = 238475 MiB

ahci driver:

P-Geo Disk 2 Cyl : 30401 H:255 S:63 Bps:512 Size : 0x1D1C5970 = 238475 MiB
Geometry D2 from : Device info and sanity

Looking at the partition overview it shows that in os2ahci.txt
It shows at line line 142:

FreeSpace? Primary 0.125 free space in MiB

Changed 8 years ago by ecsnl

Changed 8 years ago by ecsnl

Changed 8 years ago by ecsnl

comment:7 Changed 8 years ago by markus.thi

Confirmed this to be a bug in OS2AHCI. The AHCI driver should use the BIOS-provided CHS values for the physical geometry parameters.

We are working on this.

comment:8 Changed 8 years ago by stevenhl

FWIW, my analysis of the dfsee output also indicates that the handling of logical geometry for drives larger than 512GB needs to be reworked.

comment:9 Changed 8 years ago by markus.thi

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [118], version 1.18

comment:10 Changed 6 years ago by dazarewicz

  • Milestone milestone1 deleted

Milestone milestone1 deleted

Note: See TracTickets for help on using tickets.