Opened 6 years ago

Closed 6 years ago

#31 closed defect (fixed)

Disk geometry incompatible with DANIS506

Reported by: Michaelhz Owned by: dazarewicz
Priority: major Milestone: Next Version
Component: driver Version: 1.30
Keywords: Cc:

Description

When running a WD10EADS on OS2AHCI, disk geometry is not reported properly (see also ticket #29). LVM says:"DISK 1 reports a corrupt partition table". When running the HD via DANIS506 everything works fine. The problem also exists in version 1.29 (different to ticket #30).

Attachments (11)

Murmel-20130802-ahci-1.30.log (64.6 KB) - added by Michaelhz 6 years ago.
dfsdisko_os2ahci_1.zip (191.8 KB) - added by Michaelhz 6 years ago.
dfsdisko_os2ahci_2.zip (78.8 KB) - added by Michaelhz 6 years ago.
dfsdisko_danis506_1.zip (240.7 KB) - added by Michaelhz 6 years ago.
dfsdisko_danis506_2.zip (128.3 KB) - added by Michaelhz 6 years ago.
Murmel-20130803-ahci-1.30.log (64.2 KB) - added by Michaelhz 6 years ago.
This is the Runtime Debug Log file with Debuglevel 1
Murmel-20130803-ahci-1.30.2.log (64.2 KB) - added by Michaelhz 6 years ago.
This ist the Startup Debug Lofgile with BASEDEV=OS2AHCI.ADD /d:1
Murmel-20130803-ahci-1.30.3.log (64.6 KB) - added by Michaelhz 6 years ago.
This ist the Startup Debug Lofgile with BASEDEV=OS2AHCI.ADD /d:2
Murmel-20130820-ahci-1.31.log (64.2 KB) - added by Michaelhz 6 years ago.
Please find attaeched the Debug Log from 20130820-ahci-1.31. No change in behaviour.
Murmel-20130821-ahci-1.31.log (96.4 KB) - added by Michaelhz 6 years ago.
This is the Runtime Debug Log file from ahci-test-1.31-20130821.zip . Drive still not visible
Murmel-20130821-ahci-1.31.2.log (96.6 KB) - added by Michaelhz 6 years ago.
This is the Runtime Debug Log file from 2nd ahci-test-1.31-20130821.zip. Drive still not visible.

Download all attachments as: .zip

Change History (32)

Changed 6 years ago by Michaelhz

Changed 6 years ago by Michaelhz

Changed 6 years ago by Michaelhz

comment:1 Changed 6 years ago by Michaelhz

Now adding DFSDISK output for comparison, when running the HD with DANIS506.

Changed 6 years ago by Michaelhz

Changed 6 years ago by Michaelhz

comment:2 Changed 6 years ago by dazarewicz

  • Priority changed from major to Feedback Pending

The ahci debug log does not contain useful data. It looks like you captured the buffer more than once.

Please change the debug switch to "/d:1" instead of "/d:2", reboot and re-capture a new Startup Debug Log and attach it to this ticket. Thanks

Changed 6 years ago by Michaelhz

This is the Runtime Debug Log file with Debuglevel 1

comment:3 Changed 6 years ago by Michaelhz

Since I am offline the next 2 1/2 weeks I'll further provide Startup Debug Log with Debuglevel 1 and 2.
Please wait with the closing of the ticket until I'm back.

Changed 6 years ago by Michaelhz

This ist the Startup Debug Lofgile with BASEDEV=OS2AHCI.ADD /d:1

Changed 6 years ago by Michaelhz

This ist the Startup Debug Lofgile with BASEDEV=OS2AHCI.ADD /d:2

comment:4 Changed 6 years ago by Michaelhz

  • Priority changed from Feedback Pending to major

comment:5 Changed 6 years ago by dazarewicz

  • Priority changed from major to Feedback Pending

Please install this test build: http://88watts.net/download/ahci-test-1.31-20130805.zip
Use "BASEDEV=OS2AHCI.ADD /d:1" not "BASEDEV=OS2AHCI.ADD /d:2"
Reboot and capture a new testlog and attach it to this ticket.
Thanks.

comment:6 Changed 6 years ago by dazarewicz

  • Milestone set to Next Version
  • Owner set to dazarewicz
  • Status changed from new to accepted

Changed 6 years ago by Michaelhz

Please find attaeched the Debug Log from 20130820-ahci-1.31. No change in behaviour.

comment:7 Changed 6 years ago by Michaelhz

  • Priority changed from Feedback Pending to major

comment:8 Changed 6 years ago by dazarewicz

The log shows that the driver is working correctly. Thank you for testing.

comment:9 Changed 6 years ago by Michaelhz

Hm... you're welcome.
I do not know, what is working correctly. The HD is not shown at all in my system anymore. No info in LVM, no checkdisk routine at startup. So i can not use the 1TB drive.
So nothing is working here with OS2AHCI. It is only working with DANIS506.

comment:10 Changed 6 years ago by dazarewicz

  • Priority changed from major to Feedback Pending

I enhanced and fixed an issue in the user information output listing which displays the adapters and drives found. Please install this build: http://88watts.net/download/ahci-test-1.31-20130821.zip and attach a new debug log (using /d:1) to this ticket. Thanks.

Changed 6 years ago by Michaelhz

This is the Runtime Debug Log file from ahci-test-1.31-20130821.zip . Drive still not visible

comment:11 Changed 6 years ago by Michaelhz

  • Priority changed from Feedback Pending to major

Booted with DANIS506-only. The hardware setup is still operational...

(BTW: do I have to change the status from "feedback pending" back to "major" everytime?)

Daniela's Bus Master IDE Driver for OS/2 Version 1.8.14
[...]
Controller:3 Port:E800 IRQ:11 Status:OK BusMaster? Scatter/Gather?
JMicron JMB363 SATA host (197B:2363 rev:03) on PCI 3:0.0#0
Unit:0 Status:OK SMS:16 LBA NL:126 BusMaster? 3.0GBit/s BPB
Model:WDC WD10EADS-00M2B0 01.00A01
OS2:log phys BPB/BIOS IDE:log phys Total Sectors
C 60321 65535 65535 16383 Avail 1953525168
H 255 16 255 16 16 OS2 1953495585
S 127 63 127 63 63 % Used 99.99

comment:12 Changed 6 years ago by dazarewicz

I just put a new build here: ​http://88watts.net/download/ahci-test-1.31-20130821.zip
Please try that build. I think I finally got it to display all the adapters correctly.

The description of this ticket is "Disk geometry incompatible with DANIS506". With this latest build, exactly which geometries are not compatible?

Changed 6 years ago by Michaelhz

This is the Runtime Debug Log file from 2nd ahci-test-1.31-20130821.zip. Drive still not visible.

comment:13 follow-up: Changed 6 years ago by Michaelhz

About disk geometry: My assumption was, that DANIS506 reports a different geometry to LVM than OS2AHCI does. This was because of the LVM-Message "DISK 1 reports a corrupt partition table". I had the feeling (so never tested, but I can try out this. The disk does not contain important data) that repartitioning the HD under LVM leads to a disk geometry that works for OS2AHCI but not with DANIS506 anymore.

Now it seems that the initialization of the HD is wrong. Beginning with your first test build the HD in not shown neither in LVM nor in Hardware-Manager. During boot process the bios message of the JMicron controller appears and mentions the WD10EADS HD. During further eCS-boot process the WD10EADS makes some unusual noise (while the other HD's in the system generate the "normal" init-sound).

So the name of the ticket is probably wrong.

comment:14 in reply to: ↑ 13 Changed 6 years ago by dazarewicz

Replying to Michaelhz:

About disk geometry: My assumption was, that DANIS506 reports a different geometry to LVM than OS2AHCI does. This was because of the LVM-Message "DISK 1 reports a corrupt partition table". I had the feeling (so never tested, but I can try out this. The disk does not contain important data) that repartitioning the HD under LVM leads to a disk geometry that works for OS2AHCI but not with DANIS506 anymore.

Corrupt partition tables do not necessarily indicate a geometry problem (and usually do not). Both drivers report the geometry read from the DLAT sector. I recall that your disk had 2 DLAT sectors which it should never have. That is the error. If you have 2 DLAT sectors and they are different, it is undefined which one you will get.

Now it seems that the initialization of the HD is wrong.

There is no such thing as "initialization of the HD". Disks are detected, nothing more. It appears that there are no disks attached to the jmicron adapter that report themselves as ready and working. You can try adding the switch "/!r" to the OS2AHCI command line. This changes how ports are reset. Be sure to use the newest build.

comment:15 follow-up: Changed 6 years ago by Michaelhz

The /!r switch does not help. I do not understand the DLAT-comment, since I am no expert in this. The DANIS506.ADD works w/o problem.

I can try the following:

  1. Installing 1.30 of AHCI and repartitioning the HD
  2. Installing a different AHCI controller (ASMedia or Marvell)

Any better ideas?

comment:16 in reply to: ↑ 15 ; follow-up: Changed 6 years ago by dazarewicz

Replying to Michaelhz:

The /!r switch does not help.

Then that hardware does not work in that configuration. There is nothing I can do about that.

I do not understand the DLAT-comment, since I am no expert in this.

If DFSee reports "multiple DLAT sectors", as in this from your DFSee logs:

Geometry D1 from : 2nd DLAT at 0x3e IGNORED, multiple DLAT sectors!

That is an error. There should never be multiple DLAT sectors. You should either wipe the bad DLAT sector or wipe the start of the disk and start over.

The DANIS506.ADD works w/o problem.

Sorry, but that is not relevant. The same DLAT error is also reported with the Dani driver.

I can try the following:

  1. Installing 1.30 of AHCI and repartitioning the HD

Using the 1.30 driver on your system would be an EXTREMELY BAD idea. Since your hardware apparently reports bad geometries, that is probably how you got 2 DLAT sectors in the first place. You would just replicate the same problem. In 1.31 I added code to check for and fix bad geometries reported by the BIOS. Repartitioning will not remove the second DLAT sector. The error would persist.

  1. Installing a different AHCI controller (ASMedia or Marvell)

You could try that. Or you could plug your disk into the unused port on the other AHCI controller.

comment:17 in reply to: ↑ 16 ; follow-up: Changed 6 years ago by Michaelhz

Replying to dazarewicz:

Replying to Michaelhz:

The /!r switch does not help.

Then that hardware does not work in that configuration. There is nothing I can do about that.

Hm, why then DANIS506 is working with exactly this hardware?

If DFSee reports "multiple DLAT sectors", as in this from your DFSee logs:

Geometry D1 from : 2nd DLAT at 0x3e IGNORED, multiple DLAT sectors!

That is an error. There should never be multiple DLAT sectors. You should either wipe the bad DLAT sector or wipe the start of the disk and start over.

The DLAT-Message refers to a disk which is connected via DANIS506. Why should it affect OS2AHCI?

  1. Installing a different AHCI controller (ASMedia or Marvell)

You could try that. Or you could plug your disk into the unused port on the other AHCI controller.

Installed ASMEDIA and everything works well. Since DFSDISK still reports multiple DLAT I strongly believe that the problem is not related to DLAT issue. ASMEDIA Chip is treated as generic device while JMicron has some special code in OS2AHCI. Could this generate the problem?

comment:18 in reply to: ↑ 17 Changed 6 years ago by dazarewicz

Replying to Michaelhz:

The /!r switch does not help.

Then that hardware does not work in that configuration. There is nothing I can do about that.

Hm, why then DANIS506 is working with exactly this hardware?

That means absolutely nothing. There is lots of hardware that works with Dani and won't work with other drivers. Your JMicron adapter is EXTREMELY old. It reports itself as version 1.0 which is the first iteration when the AHCI spec first came out. That adapter probably violates the spec in some way. THAT is why it does not work. If you want use that adapter, use DANIS506 to run it.

If DFSee reports "multiple DLAT sectors", as in this from your DFSee logs:

Geometry D1 from : 2nd DLAT at 0x3e IGNORED, multiple DLAT sectors!

That is an error. There should never be multiple DLAT sectors. You should either wipe the bad DLAT sector or wipe the start of the disk and start over.

The DLAT-Message refers to a disk which is connected via DANIS506. Why should it affect OS2AHCI?

It is an error on the disk and will affect EVERY PIECE OF SOFTWARE that accesses it, ALL DRIVERS, LVM, EVERYTHING!

Installed ASMEDIA and everything works well.

Of course it does. That PROVES WITHOUT ANY DOUBT that your JMircron adapter doesn't work in AHCI mode.

Since DFSDISK still reports multiple DLAT I strongly believe that the problem is not related to DLAT issue.

What is "the problem"??? I only see 2 issues:

  1. Your JMicron adapter doesn't work properly (is not completely AHCI compliant). There is nothing I can do about that. Perhaps if I had the hardware in my lab and had all the appropriate hardware analysis tools and I could figure out exactly what is out of compliance, maybe I could work around the hardware defect. But why would I waste all that time? Accept the fact that it doesn't work and either throw it away and get a new adapter, or use the DANI driver on it. This item is a clearly a "wont fix".
  1. You have multiple DLAT sectors on one or more of your disks. This is an error and is a catastrophe waiting to happen. DLATs are part of the LVM system. LVM probably wrote a bad DLAT due to a bad disk geometry being reported at some time in the past. You should remove the bad DLAT sector. THIS IS NOT AN AHCI PROBLEM.

ASMEDIA Chip is treated as generic device while JMicron has some special code in OS2AHCI. Could this generate the problem?

No.

There is nothing remaining in this ticket related to AHCI, so it will be closed.

comment:19 Changed 6 years ago by Michaelhz

  • Resolution set to wontfix
  • Status changed from accepted to closed

OK, THANKS FOR YOUR EFFORT!
Still not fully convinced, since there are still two open tickets handling with disk geometry item (#27, #30). One ticket is about a similar story (DANIS506 work, OS2AHCI not).
But it is clear for me not to spend more effort on this item. There are more important things to do.
Nevertheless this shows once more the importance about a "working hardware database for eCS users", preferably connected to the svn-wiki.
To get my system running, I bought 3 different AHCI-Adapters to get at least one working properly. I could have saved a lot of money with an existing database.

comment:20 Changed 6 years ago by dazarewicz

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Geometry issue fixed in version 1.31

comment:21 Changed 6 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.