Opened 7 years ago

Closed 6 years ago

#557 closed defect (duplicate)

Dell Vostro 1520 resume support

Reported by: ydario Owned by: dazarewicz
Priority: major Milestone: Release 4.00
Component: Suspend-Resume Version: 3.21.02
Keywords: suspend resume Cc: ydario

Description

Suspend/Resume? is not working correctly on Dell Vostro 1520 notebook.

While suspend is working, resume doesn't.

Closing the screen correctly activates suspend, I see power led start blinking.

Opening the screen causes only some cdrom movement (like on power on),then nothing. Adding /VBE causes some hard disk activity to be shown periodically (random hd led activity) after cdrom movement.

Attachments (1)

PAPERINO-20120907-acpi-3.21.02.zip (62.3 KB) - added by ydario 7 years ago.
testlog.cmd output.

Download all attachments as: .zip

Change History (26)

Changed 7 years ago by ydario

testlog.cmd output.

comment:1 Changed 7 years ago by dazarewicz

I assume you have read the documentation on suspend and resume?

Debugging resume is extremely difficult as there is really no log file or anything you can provide that will allow me to help you. The PSD and Daemon are known to work. The strategy is to find which driver is not working and why. Unfortunately, I cannot help you with that.

Also I noticed from your log that the ACPI on this system produces many errors indicating that your ACPI tables are bad. The errors seem to be related to the second battery, though, so the errors are not directly affecting your resume but they do indicate that there are problems in the ACPI tables. Dell systems are known to be problematic so you may not be able to get resume to work on that system. I have a Dell Inspiron laptop that won't resume and there has been nothing I can do about it. It just won't work.

comment:2 Changed 7 years ago by ydario

  • Cc ydario added

comment:3 follow-up: Changed 7 years ago by ydario

Yes, already checked docs.

About drivers, it seems to me it stops too early.

isn't there a way to write on the screen?

comment:4 in reply to: ↑ 3 ; follow-up: Changed 7 years ago by dazarewicz

Replying to ydario:

Yes, already checked docs.

About drivers, it seems to me it stops too early.

Stuff happens pretty fast. I assume that you never get the graphical screen repainted, correct?

isn't there a way to write on the screen?

In acpid.cfg you can enable logging to the screen for the Daemon by setting

LogToScreen? = 1

Some messages are output by the daemon.

The only other way to get debug information out is through a serial port. I have been trying to think of other ways to help people debug resume, but as of now the serial port is the only way.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 7 years ago by ydario

Why I'm not getting email notifications about changes? :-(

Replying to dazarewicz:

Stuff happens pretty fast. I assume that you never get the graphical screen repainted, correct?

right, but I also can't see a blinking cursor at resume, so probably here it is hanging really soon.

LogToScreen? = 1

Some messages are output by the daemon.

even at resume? but without cursor I assume I can't get daemon output too.

but as of now the serial port is the only way.

no serial port obviously. What about some nice music? ;-) or some beep sequence.

comment:6 in reply to: ↑ 5 Changed 7 years ago by dazarewicz

Why I'm not getting email notifications about changes? :-(

Put your whole e-mail address in the Cc: field. Automatic emails from Trac is broken so you have to use Cc:

Stuff happens pretty fast. I assume that you never get the graphical screen repainted, correct?

right, but I also can't see a blinking cursor at resume, so probably here it is hanging really soon.

LogToScreen? = 1

Some messages are output by the daemon.

even at resume? but without cursor I assume I can't get daemon output too.

That is probably true. There is a full screen session active at that time so you should see a cursor. The resume is probably not getting that far. Immediately upon getting control after the system wakes up, the daemon outputs: "DoSuspend?: Wakeup"

Prior to that, immediately after getting control and running the video BIOS init routine (if /VBE enabled) while still in Real Mode, the string "Wakeup is beginning..." is written directly to to the first line of video memory. This occurs only a few instructions after the CPU starts running again.

If you don't see either the "Wakeup is beginning..." or the "DoSuspend?: Wakeup", then probably the system is not waking up. This is exactly the problem I have with my Dell laptop.

but as of now the serial port is the only way.

no serial port obviously. What about some nice music? ;-) or some beep sequence.

Hmmm... That could be possible.

comment:7 Changed 7 years ago by dazarewicz

Opening the screen causes only some cdrom movement (like on power on),then nothing. Adding /VBE causes some hard disk activity to be shown periodically (random hd led activity) after cdrom movement.

This actually doesn't sound correct. There should not be any CDROM "movement" at all, and there should not be any hd activity at this point given what you said in the previous post.

My guess is that the wakeup vector is not working correctly in the BIOS on this system and the BIOS is vectoring the CPU to the wrong place on wakeup.

comment:8 Changed 7 years ago by ydario

  • Cc ydario removed

comment:9 Changed 7 years ago by ydario

I don't see a way to add an email to CC field, always 'ydario' is the only choice. email notifications are working in ports/rpm tracs (at least for me).

comment:10 Changed 7 years ago by dazarewicz

  • Cc mc6530@… added

It is something about the server setup.

I don't understand what you are saying about the CC field. The CC field is a simple typeable entry field. there are no choices. You just type whatever you want.

comment:11 Changed 7 years ago by stevenhl

IIRC, the problem is that Adrian has not gotten the LDAP interface working for TRAC emails. This means that TRAC can not covert the reporter's userid to an e-mail address. The reason the cc: field works is because you can enter a valid e-mail address.

Each project has a hardcoded list of e-mail addresses that receive notifications for every TRAC ticket. This list typically includes the project admins and others that ask to be on the list. This list works because it bypasses the LDAP lookup.

comment:12 Changed 7 years ago by ydario

For me the CC field is not an entryfield: I just see

Add to Cc: ydario CB

where CB is a check box. No other ways to edit that part of the ticket.

comment:13 Changed 7 years ago by stevenhl

My bad. I was looking at the admin screen which shows full e-mail address.

When you log in as an authenticated user, you get the checkbox and you did add your e-mail address to the cc: list. It is only TRAC e-mails that have LDAP lookup issues. When you add yourself to the cc: list, TRAC stores your e-mail address in the cc: list, so there's no LDAP lookup required.

comment:14 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending

I had no idea that you were not seeing the same modify options as I was.

Please look at the "Modify Ticket" section again and see if you can now edit the CC: field differently. I attempted to change the Trac permissions for authenticated users to allow this.

comment:15 Changed 7 years ago by ydario

  • Cc yd@… added; mc6530@… removed

ok, now CC shows an editable entryfield with my email address.

comment:16 Changed 7 years ago by dazarewicz

  • Milestone changed from Feedback pending to Release Version 4.0.0

comment:17 follow-up: Changed 7 years ago by yoda

Have you checked your preferences in this specific project ? It is not enough to have a netlabs userid with an associated email, you need to add your email to your preferences for each specific project. When that is done, you get email notification for all your tickets.

comment:18 Changed 7 years ago by yoda

  • Cc acpi@… added; yd@… removed

comment:19 Changed 7 years ago by yoda

Changed 2 seconds ago by yoda

  • Cc acpi@… added; yd@… removed

OK, some admin screwed up here. I just tried to add myself - sorry you got removed, Yuri. Admins: please get it back as it was.

comment:20 Changed 7 years ago by ydario

  • Cc ydario added; acpi@… removed

comment:21 Changed 7 years ago by ydario

I tried to re-add myself, but this removed yoda address...

comment:22 in reply to: ↑ 17 ; follow-up: Changed 7 years ago by ydario

Replying to yoda:

Have you checked your preferences in this specific project ?

Ah, I didn't know of this Trac feature, since I'm also admin on the other netlabs project. thanks for tip.

comment:23 in reply to: ↑ 22 Changed 7 years ago by yoda

I tried to re-add myself, but this removed yoda address...

Exactly the same that happened for me. It is not supposed to work like that, so I hope they will get it back on track

Have you checked your preferences in this specific project ?

Ah, I didn't know of this Trac feature, since I'm also admin on the other netlabs project. thanks for tip.

I'm afraid that only very few are aware of this, and that is why end users never gets email notifications, and for same reason often forgets about their tickets.

I'm pretty sure adding email to preferences was not needed earlier - so this seems to be some newer 'feature' :-/

comment:24 Changed 6 years ago by dazarewicz

  • Component changed from ACPI PSD to Suspend-Resume

comment:25 Changed 6 years ago by dazarewicz

  • Resolution set to duplicate
  • Status changed from new to closed

Consolidating all "resume does not work" problems into a single ticket #585

Note: See TracTickets for help on using tickets.