Opened 7 years ago

Closed 6 years ago

#528 closed defect (No Change Needed)

trap e possibly serial port related

Reported by: dryeo Owned by: dazarewicz
Priority: major Milestone: Release 4.00
Component: ACPI PSD Version: 3.19.14
Keywords: Trap E Serial Port Cc: dave.r.yeo@…, dryeo

Description

When turning off my modem I got the attached trap e. Previously I saw a similar trap when my phone rang, unluckily batteries were dead for that one.

Other then these 2 traps ACPI has been working fine here with no command line options and both cores are enabled.

eCS 2.1, core2duo E6300, MB P5PE-VM, USR Robotics 56K FaxModem? (Sportster), dial up internet connection.

Attachments (2)

acpi_trap_e.png (244.3 KB) - added by dryeo 7 years ago.
Screen Shot of trap screen
ACPI.MTE (2.4 KB) - added by dryeo 7 years ago.
Theusus4 output of ACPI's MTE

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by dryeo

Screen Shot of trap screen

comment:1 Changed 7 years ago by dryeo

I forgot to add, serial port has the usual IRQ (4) at IO port 0x3f8

comment:2 Changed 7 years ago by dazarewicz

  • Status changed from new to assigned

I need more information for this issue.

If you don't already have Theseus, download it from:

http://www.os2site.com/sw/util/memory/thes4001.exe

This is a self-extracting zip file. CD to a directory of your choice and execute it to unzip it.

To run from the command line, use

theseus4.exe

From the main menu, use

System->General system->Modules

to display the module list.

Scroll to the end of the window and double click on the address in MTE @ column for ACPI to display the MTE.

From the window menu, use

Output->SaveAs?

to write window contents to a file.

Attach that file to this ticket. Thanks.

Changed 7 years ago by dryeo

Theusus4 output of ACPI's MTE

comment:3 Changed 7 years ago by dazarewicz

The trap occurs because a bad pointer is used when searching the ACPI namespace. This could be caused by a number of things including: an error in the ACPI tables, a bug in the Intel AcpiCA code, setting up the AcpiCA code incorrectly, etc. A trap dump would be needed to investigate further.

However, the evidence suggests that a wake up event is triggering the problem. Check your BIOS settings and make sure that no modem events and no serial port events are enabled to wake up the system. Please let me know if they were enabled and if disabling them stops the trap from occuring.

comment:4 Changed 7 years ago by dryeo

The only wake up event in the BIOS was for pressing the space key on my PS2 keyboard which I turned off as this computer does not go to sleep, probably due to using SNAP.
I did get another trap e today with the same address. If you want the screen shot let me know.
This board is old, using Intel 865G + Intel ICH5 which I've been told is kinda Micky Moused to support SMP so an error in the ACPI tables or bug is quite possible. I do have the newest BIOS.
I can also set my system up to get a trap dump if you'd like. I believe Steven Levine has detailed instructions for doing it

comment:5 Changed 7 years ago by dazarewicz

No need for another trap screen. With the information you provided so far I was able to exactly identify the instruction causing the trap. It is deep in the Intel code. A trap dump might help identify how it got there, so yes I'd like a trap dump if possible.

comment:6 Changed 7 years ago by dryeo

I should mention that with acpi-3.20.1 instead of a trap, I now get a total system freeze that requires the reset key to recover from

comment:7 Changed 6 years ago by dryeo

  • Cc dryeo added
  • Resolution set to No Change Needed
  • Status changed from assigned to closed

Setting the dialer to always keep the comm port open seems to be a workaround for this trap, at least with 3.19.4. Newer versions cause hangs or kernel traps that happen even with the comm port disabled in BIOS so I'll open a new ticket for that and close this one.

Note: See TracTickets for help on using tickets.