Opened 7 years ago

Closed 7 years ago

#496 closed defect (fixed)

Asus P5E3 dual core CPU IRQ problems

Reported by: microdrome Owned by: pasha
Priority: critical Milestone: Release version 3.19
Component: ACPI PSD Version: 3.18
Keywords: irq Cc:

Description

Multiple irq's are on the same device no matter the acpi version. Boots o.k with /smp /apic ,but apps close randomly after a while Ecomstation 2.0 GA ,SATA ,uniaud ,Marvell Yukon 88E8056 LAN When booted with the orginal usb drivers only 3 controller out of 8 are found - experimenting with the rebuild ones from Lars Erdmann (V6) gives better results- all the controllers are found ,but still share irq's Especially bad is the uniaud driver which share the same irq as the sata driver

Tried different acpi bios ungrade to the latest

Booting without / smp or / apic makes the system totally unusable

Attachments (4)

acpica.log (19.9 KB) - added by microdrome 7 years ago.
rmview.log (1.6 KB) - added by microdrome 7 years ago.
acpica.2.log (21.7 KB) - added by microdrome 7 years ago.
log with ACPI319CR4.ZIP
acpica.3.log (22.6 KB) - added by microdrome 7 years ago.
new log with right dll

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by microdrome

Changed 7 years ago by microdrome

comment:1 Changed 7 years ago by microdrome

Is there no solution at all ?? This is the 3rd motherloard i purchased which is not stable to use with ecomstation. I am no simple user ,my applications demand a stable (business) machine which is on 14 hours a day and with many devices connected - a lot usb -

And i have do read all the documentation there is on acpi and all its problems that can arise. Just cannot figure out what to do next.

Please help ...

comment:2 Changed 7 years ago by pasha

  • Owner changed from eco to pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

acpi319CR4.zip

comment:3 Changed 7 years ago by pasha

to add, also I need in log after boot. I mean acpica.log

comment:4 Changed 7 years ago by microdrome

All done , As far as i can see no different resuls

Changed 7 years ago by microdrome

log with ACPI319CR4.ZIP

comment:5 Changed 7 years ago by pasha

Sorry, check acpidaemon.exe is in \OS2\ and acpi32.dll is in \OS2\DLL or attach log from acpidaemon.exe.

comment:6 Changed 7 years ago by microdrome

sorry my mistake ,the dll was not copied (was locked) new log attached

Changed 7 years ago by microdrome

new log with right dll

comment:7 Changed 7 years ago by pasha

Now log is right. What is the applications? I mean applications, which randomly closed

comment:8 Changed 7 years ago by microdrome

I am still stress testing ,so far things are better than before ,but i have not yet done extensive usb testing - i wanted to wait with that until i now more about if everithing keeps working with no input.

My previous problem was dropping network ,drive access problem after 1 hour or so with no human activity

It is on now for 2-3 hours and still going with internet radio playing and firefox open after much activity ...

But there are still the same shared irq's ,is that no problem ?

comment:9 Changed 7 years ago by microdrome

update: after 4 hours the network went down ..... it is still in that state ,is there a log which i can use (generate) which is usefull ?

comment:10 Changed 7 years ago by microdrome

  • Resolution set to fixed
  • Status changed from new to closed

big problem found: While i was still wandering why this motherboard had so much problems and the previous one (same model which died suddenly) had good results ,i accidently stumbled on a hardware problem. This board was a (new?) replacement for the 1 st one which died after moving it to a new cabinet ,it was returned from ASUS this way since they could not repair the orginal one.

All this time the board was screwed in a temperary test cabinet with most things not bolted. So were the usb brackets ,3 of them just hung loose. As this board was still under tests ,i usually used it as a internet radio player and so i heard it immidiately when the network dropped. In this case i noticed a sound distortion when i moved one of the loose usb brackets. After a few seconts the audio stream stopped and the network was down and the drives were not accessiable (must be the long time out of the peer )

To make things short ,i did some measurement and to my surprise the was 3.3 Volts on 1 usb bracket- which should be 0 (another faulty board) And so things were clear ,because that bracket was touching the cabinet sometimes and shorted the 3.3 V . I isolated the bracket and now the network remains up (for days now)

After all no acpi problem as i first expected - Too bad of the wasted time , i hope you can forgive me (pasha..) -never expected this (and i do electronic repairs as a day job)

Now back to massive usb testing ,the last thing i want to make sure before i use this board for my main office computer.

Note: See TracTickets for help on using tickets.