Opened 9 years ago

Closed 6 years ago

#359 closed defect (Unsupported Version)

SMP APIC, Compaq F761

Reported by: snapdrgn Owned by: eco
Priority: major Milestone: Release version 3.19
Component: ACPI PSD Version: 3.14
Keywords: Boot failure Cc: snapdrgn

Description

Compaq F761 Notebook: AMD Athlon processor

Note: F7xx notebooks are the essentially the same as HP 6000 series notebooks.

ACPI Rev 3.13 boots fine with /SMP /APIC There is a conflict between NVIDIA Chipset NIC Driver (NVETH) 0.0.5 and the latest Uniaud from Mr. Smedley with Uniaud deleting the NVETH IRQ. Uniaud is remmed out in my config.sys.

New tests: ACPI Rev 3,14 APM Rev 1.28

Boots ok with no switches. see acpi-log-Compaq-F761-HP-6000-NoSMP.ziq Boots ok with /SMP /PIC but IRQ assignments suck. see acpi-log-Compaq-F761-HP-6000-SMP-PIC.ziq Fails to boot with /SMP /APIC. Debug ACPI.PSD version used: see screen picture crash.jpg

Failure mode: Loads all .sys drivers, then clears screen and briefly accesses the disk drive periodically at approximate 4 - 5 second interval. Message on screen after long interval:

Check IRQ AcpiWaitOBF ctl=29 OBF=1 EC arm "_Q80" N:0 Cur:0 Unmask IRQ0 mask 0xFF3BACFC Real: 0XFFEBB8F4

After approximately 10 minutes the system beeps on disk access then after a few more accesses crashes in HPFS.IFS.

Attachments (5)

acpi3-14-Compaq-F761.ziq (195.1 KB) - added by snapdrgn 9 years ago.
zipped logs, screen image, failure discription
acpi31x_CompaqF761.ziq (20.7 KB) - added by snapdrgn 9 years ago.
acpi.logs rev: 3.13 & 3.14 minimal config
acpi314crash.jpg (93.9 KB) - added by snapdrgn 9 years ago.
acpi_BAT.ziq (6.0 KB) - added by snapdrgn 9 years ago.
acpi$.log and rmview /irq files
apm_acpi_compaqF761.zip (6.5 KB) - added by snapdrgn 9 years ago.

Download all attachments as: .zip

Change History (27)

Changed 9 years ago by snapdrgn

zipped logs, screen image, failure discription

comment:1 Changed 9 years ago by snapdrgn

  • Cc snapdrgn added

comment:2 Changed 9 years ago by eco

VIA chipset

e-co:

check your system: http://ecomstation.ru/projects/acpitools/download/acpi-test.cmd

try simplify the setup, disable secondary drivers

read different suggestions on the second part of: http://ecomstation.ru/projects/acpitools/?action=trouble-acpi

Pasha:

try boot without acpidaemon, or load acpidaemon from startup.cmd

try disable uniaud

if using amouse then add a switch http://ecomstation.ru/projects/acpitools/?action=acpi-smp-drv

comment:3 Changed 9 years ago by eco

e-co:

? APIC SMP OK with 3.13, doesn't work with 3.14

so.. it's necessary offer other suggestion.

comment:4 Changed 9 years ago by eco

e-co:

Pasha: 3.13 <> 3.14 so, this may be related to Intel acpi-ca

comment:5 Changed 9 years ago by ecsnl

For fun do ALT F2 when booting the system to see what happens ?

Does it then become slow after loading the the device drivers ? Or does it hang after pmshell.exe ?

Roderick Klein Mensys

comment:6 Changed 9 years ago by snapdrgn

No joy:(
Per acpi_test.cmd:
removed PCIBUS.SNP from snoop.lst
upgrade to danis506.add 1.8.5
corrected acpidaemon version

Test: acpi 3.14
Minimal drivers loaded, all run commands remmed out

Boot with protshell=cmd.exe OK with minimal drivers using acpi /SMP /PIC
Video flashes on ~1 second intervals when using FTE.exe editor.
system hangs at FTE exit. Same result as "exit" from the last cmd.exe session.
ctrl-alt-del fails to reboot. Power down required.

Boot with protshell=cmd.exe Fails with acpi /SMP /APIC
Drivers load ok (alt-F2)

Extra drivers make no difference in behaviour.
hang occurs after drivers loaded, before protshell loaded.

comment:7 Changed 9 years ago by pasha

acpi log?

comment:8 Changed 9 years ago by snapdrgn

No acpi.log. The system got hosed and i had to reinstall from a zip file. I am going to try adding acpi to a functional maintanence partition today.

Changed 9 years ago by snapdrgn

acpi.logs rev: 3.13 & 3.14 minimal config

comment:9 Changed 9 years ago by snapdrgn

Tested rev 3.13 and 3.14 under identical conditions with a minimal system.
test 1. no switches: both revs boot ok with one processor initialized
test 2. /SMP /PIC : both revs boot ok with two processors initialized
test 3. /SMP /APIC : 3.13 boots ok
test 3. /SMP /APIC : 3.14 hangs after loading os2cdrom.dmd.

fan turns on almost immediately.
long delay with no disk access. Normal under all configurations.
disk momentarily accessed every 4~5 seconds.
normal behavior is one brief disk access,

followed by a very long access and
loading of run= executables then cmd.exe shell

C-A-Del is non-functional

See acpi31x_CompaqF761.ziq which contains acpi logs, notes and config.sys

comment:10 Changed 9 years ago by pasha

  • Owner changed from pasha to Pasha

What is if remming os2cdrom.dmd ?

About CAD, install debug acpi, open full screen cmd session, press CAD - the attach photo of screen

Changed 9 years ago by snapdrgn

comment:11 Changed 9 years ago by snapdrgn

Remmed os2cdrom.dmd out; no change in behavior.
did one (1) CAD with debug acpi 3.14, results in acpi314crash.jpg
machine did not reboot.

comment:12 Changed 9 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:13 Changed 9 years ago by stevenhl

  • Owner changed from Pasha to pasha

Changed 9 years ago by snapdrgn

acpi$.log and rmview /irq files

comment:14 Changed 9 years ago by snapdrgn

We have Boot!


acpi_BAT (3.14) boots and correctly finds all devices.
Uniaud, Genmac and NVeth 0.0.5 IRQs coexist.
I have not yet tested what actually works and i will be
on the road for a few days.
pasha, you da man! Thanks!

comment:15 Changed 9 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

Please let us know the results of your full testing. Please retest 3.15 when it is released. Thanks.

comment:16 Changed 9 years ago by pasha

  • Owner pasha deleted

Changed 9 years ago by snapdrgn

comment:17 Changed 9 years ago by snapdrgn

Hi, I checked apm operation. shutdown works. battery widget works.

suspend does not work.

states S1, S2 are reported as Not_Supported.

states S3 and S4 shut things down, i think. The screen shuts down anyway.

When in S3 or S4 mode there is no recovery. Power off is necessary.

i am using sdd video driver currently. May switch to SNAP.

Hard drive is SATA.

Desired option is to shut down the video backlight, and maybe throttle the cpu's in suspend mode to save power.
Does snap or doodle's screensave do this?

Otherwise things appear to be stable.

comment:18 Changed 8 years ago by GeRash

  • Owner set to pasha

comment:19 Changed 8 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.19

comment:20 Changed 7 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

acpi319PollingFullOnly.zip

comment:21 Changed 7 years ago by pasha

  • Owner changed from pasha to eco

feedback pending -> mensys stage

comment:22 Changed 6 years ago by dazarewicz

  • Resolution set to Unsupported Version
  • Status changed from new to closed

This ticket is really old and not really relevant to the current software. If you still have problems with the current version, please open a new ticket.

Note: See TracTickets for help on using tickets.