Opened 9 years ago

Closed 8 years ago

#343 closed defect (unknown)

acpi v3.14 and nForce430/MCp61 chipset

Reported by: losepete Owned by:
Priority: major Milestone: Release version 3.18
Component: ACPI PSD Version: 3.14
Keywords: Cc:

Description (last modified by eco)

Hi

Hardware: Asus M2N mainboard using the nForce430/MCP61 chipset

acpi v3.14 installed

No change from v3.13 and previous releases observed so far:-

System does not shutdown/reboot using the eCS2.0RC5 supplied eStyler; shutdown.exe may or may not work - it sometimes hangs and sometimes reboots instead of power off.

Cannot boot without the /!NOD switch - posted this problem previously and read that this should be fixed in v3.12; I am reporting about v3.14...

The /TMR and /CD switches also required.

Only change noted here in moving from v3.11 to v3.14 is the change in version number...

Hopefully v3.15 will come closer to working with this system.

Regards

Pete

Attachments (1)

acpi-log-Model-of-your-PC.ziq (70.5 KB) - added by losepete 9 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 9 years ago by pasha

do you try use PowerOff?.exe ?

comment:2 Changed 9 years ago by eco

  • Description modified (diff)

e-co:

Can you remind me why don't you like /!NOD switch? What are the restrictions for you in everyday usage of the OS in this case?

comment:3 Changed 9 years ago by losepete

The answer to the above question exists in ALL my previous reports.

The M2N mainboard with Vidia nForce430/MCP61 chipset WILL NOT BOOT without the /!NOD switch if using the /APIC switch.

This goes back to v2.22, or thereabouts, that being my first attempt at getting ACPI working with this system.

So, why do I not like booting using the /!NOD switch?

Because, as I understand it from the skimpy documenation, use of the /!NOD switch nullifies the /APIC switch.

I have also been told on several occasions that the system should boot without that switch - within this reporting system.

I also understand from reading posts within this reporting system and elsewhere tha it is purely accidental that use of the /!NOD swicth allows some nVidia chipset based systems to boot.

Enough reasons?

comment:4 Changed 9 years ago by losepete

No, I do not use PowerOff?.exe - that looks nasty.

I do use either the Warp4 shutdown - no eStyler extended shutdown options - or Ctrl-Alt-Del to reboot and simply press the Off button.

comment:5 Changed 9 years ago by eco

  • Description modified (diff)

We should understand, what is the problem? ACPI or shutdown managers? Please use test utility PowerOff? (ACPI utilities)

comment:6 Changed 9 years ago by eco

Please attach acpi logs so we can see what happens with your PC. You can run ACPI logs collector.

Changed 9 years ago by losepete

comment:7 Changed 9 years ago by losepete

Logs: A New copy attached.

We did this awhile back and you were not interested in the Logs because the system had been booted with the /!NOD switch.

You wanted Logs from the system when booted without using the /!NOD switch which is not possible as the system will not boot without the /!NOD switch.

I refer you to ticket #261

The attached logs are from the system booted using the /!NOD switch.

Shutdown/Reboot/Power? Off:

I would take a guess that the problem is ACPI related.

The system will not Shutdown/Reboot/Power? Off using the eStyler extended shutdown with ACPI drivers installed.

The system will happily perform the above actions when ACPI is not installed.

I've looked at the docs for Poweroff.exe and will not be using that, Thanks.

poweroff.doc:-

PowerOff? allows power off your computer even if APM.ADD driver is not loaded

ATTENTION: You can loss the data if using this utility! There is no cache empty, etc.

If you need safe PowerOff? then use:

  • Fresh eStyler poweroff should work.
  • Power wps objects supports poweroff

The ATTENTION bit tells me not to use this program - and the final paragraph is incorrect as eStyler poweroff does not work.

comment:8 Changed 9 years ago by eco

e-co:

I am sorry to trouble you, please repeat, what is the problem? with DOS sessions? or other problem?

comment:9 Changed 9 years ago by losepete

Explain why it is necessary to use the /!NOD switch when using the /APIC switch

comment:10 Changed 9 years ago by losepete

Just to let you know the latest update to eStyler seems to work fine with ACPI 3.14 - with the exception that if I add cupsd.exe to the Terminate list the system needs to be told to power off a 2nd time before it works. Terminating cupsd.exe before Shutdown works without any problem here.

If you need to let anyone else know about this eStyler update the only place it seems to be available from is the eCS Bugtracker - login and look for bug 001527, the update package is listed there.

comment:11 Changed 9 years ago by eco

e-co:

Please tell us why HighIRQs are important for you? Here is the node ticket (head of all tickets related to /!NOD): http://svn.netlabs.org/acpi/ticket/258#comment:9

comment:12 Changed 9 years ago by pasha

If PowerOff?.exe is work, so problem outside of acpi

comment:13 Changed 9 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:14 Changed 9 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

comment:15 Changed 9 years ago by pasha

  • Owner pasha deleted

comment:16 Changed 9 years ago by losepete

ACPI-APIC-BAT.ZIP and ACPI315PRE.ZIP have both been tested and found to fail to boot at all. See http://svn.netlabs.org/acpi/ticket/392 ACPI315PRE fails to boot

I repeat my previous question as it seems we have an "understanding issue" here: Explain why it is necessary to use the /!NOD switch when using the /APIC switch on this system.

comment:17 Changed 9 years ago by pasha

  • Owner set to pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPIPRE2.ZIP

Need test with /SMP and /SMP /APIC

comment:18 Changed 9 years ago by pasha

  • Owner pasha deleted

comment:19 Changed 8 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.18
  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.