Opened 11 years ago

Closed 10 years ago

#297 closed defect (unknown)

AMD dual-core (nVidia chipset) STILL needs /!NOD with 3.11!?

Reported by: AlanB Owned by:
Priority: major Milestone: Release version 3.18
Component: ACPI PSD Version: 3.11
Keywords: nVidia, AMD Cc:

Description

My Asus M2N-SLI Deluxe machine (nVidia) still needs /!NOD to enable the LSILogic SCSI adapter. I've tried REMAPping the SCSI adapter's IRQs, but either I'm doing it wrong or ACPI 3.11 still isn't up to the task.

Attachments (1)

acpi-log-Asus_M2N-SLI_DeLuxe.ziq (98.7 KB) - added by AlanB 11 years ago.

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by AlanB

comment:1 follow-up: Changed 11 years ago by pasha

What is acpi version were was all OK? I mean what you try before 3.11

comment:2 in reply to: ↑ 1 Changed 11 years ago by AlanB

Replying to pasha:

What is acpi version were was all OK? I mean what you try before 3.11

I have almost always needed /!NOD -- except with 3.07, I think. I have tried every version since 3.0, if not earlier.

But I thought that ACPI 3.11 was supposed to handle the peculiarities of the nVidia chipset better. I thought I had read somewhere that the fact that /!NOD solves many problems with the nVidia chipset was not what that switch was intended to do and that a future version (3.11, I thought) would do things the right way.

In summary, it works with /!NOD, but I was expecting that there would now be a new switch that would render /!NOD unnecessary.

comment:3 Changed 11 years ago by losepete

Sorry to jump in but having the Asus M2N mainboard, nForce430/MCP61 chipset I can confirm that /!NOD is required to boot.

I have not met a version of ACPI that does not require that switch with this chipset. Trying to boot without that switch results in the system failing to boot - gets stuck after loading usbehcd.sys, usbohcd.sys is displayed onscreen (using ALTF2ON.$$$ to view drivers loading). If I REM the usbohcd.sys line then the system gets stuck with the next usb basedev line - usbd.sys.

Guess I could REM the usbehcd.sys line and see if the system will boot... Will report back on this.

I do know that the nForce4 chipset - slightly earlier nVidia chipset, does not require the /!NOD swich with ACPI V3.11 and all seems to work fine.

comment:4 Changed 11 years ago by eco

e-co:

I am sorry to trouble you, please repeat, what is the problem? with DOS sessions? or other problem?

comment:5 Changed 11 years ago by eco

e-co:

Please tell us why HighIRQs are important for you? Here is the node ticket (head of all tickets related to /!NOD): http://svn.netlabs.org/acpi/ticket/258#comment:9

comment:6 Changed 11 years ago by pasha

where is problem?

comment:7 Changed 11 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:8 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

comment:9 Changed 11 years ago by pasha

  • Owner pasha deleted

comment:10 Changed 10 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.18
  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.