Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#274 closed defect (fixed)

single /APIC switch => PC hangs

Reported by: eco Owned by: pasha
Priority: major Milestone: Release version 3.11
Component: ACPI PSD Version: 3.10
Keywords: Cc:

Description

e-co:

Old bug, I have seen 3-5 similar reports,

SMP kernel

  • /APIC => PC freezes

<Roderick> PSD_SET_ADV_INT_MODE <Roderick> APIC0 IOMASK fff6ffff mask fff68cfg <Roderick> It hangs <Roderick> No, it freezes. <Roderick> shutdown pic mask fff68cfg

  • no switches => PC boots
  • /SMP /APIC => PC boots

Change History (4)

comment:1 Changed 11 years ago by eco

e-co:

OK, the problem is repeatable. tested with ASUS A6Ja

comment:2 Changed 11 years ago by eco

нужна защита от дурака. если /APIC без /SMP, то /APIC отключить

comment:3 Changed 11 years ago by eco

  • Resolution set to fixed
  • Status changed from new to closed

seems to be fixed in ACPI 3.11

comment:4 Changed 11 years ago by eco

todo:

  • test 1 CPU PC and /SMP /APIC - should work
Note: See TracTickets for help on using tickets.