Opened 12 years ago

Closed 7 years ago

#249 closed defect (unknown)

Suspend/resume, Thinkpad T60, s/r doesn't work anymore

Reported by: eco Owned by:
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.09
Keywords: Suspend Cc:

Description

e-co:

Computer: T60, testing suspend/resume

From: Thorolf

eCS 2.0 RC4 includes ACPI 3.05 (?), suspend/resume works fine.

ACPI 3.08, 3.09 - suspend/resume -> trap on resume.

Attachments (6)

acpi.log (19.1 KB) - added by eco 10 years ago.
ACPID.CFG (3.5 KB) - added by eco 10 years ago.
acpiirq.log (76 bytes) - added by eco 10 years ago.
DSC00018b.jpg (157.8 KB) - added by eco 10 years ago.
DSC00019b.jpg (152.5 KB) - added by eco 10 years ago.
DSC00020b.jpg (128.0 KB) - added by eco 10 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.10 to Feedback pending

comment:2 Changed 11 years ago by eco

From: Thorolf

I just testet it on my T60 with eCS20rc1 (but all drivers updated to the latest level) and it's still not running. I only a "funny" screen and then have to switch of my system.

comment:3 Changed 11 years ago by eco

Thorolf talks about ACPI 3.10

comment:4 Changed 11 years ago by eco

Thorolf adds:

I installed eCS20rc5 on my T60, with ACPI 3.10 I only get a coloured screen and then I have to power off the system.

I upgraded ACPI to 3.10 and ALSA to 1.0.17 and tested again:

Suspend now seems to work most times, network-ping stops, I get very short the coloured screen, then it switches off the screen and the "moon"-LED goes on. Most times meens that I tried it 4 times and 3 times it went into resume and one time it stayed with the coloured screen until I switched off the system.

But the system never comes up if I want to resume, once I got a Trap 0008 and the other times the screen stayed off and I had to power off the computer.

comment:5 Changed 11 years ago by eco

  • Summary changed from T60, Suspend/resume doesn't work anymore to Suspend/resume, Thinkpad T60, s/r doesn't work anymore

comment:6 Changed 11 years ago by eco

Thorolf:

I installed RC6 plus ACPI 3.1.3 for testing on my T60 today.

The first results:

  • The installation of ACPI 3.1.3 (acpifu-20081127.wpi), changing some

acpid.cfg-setting to enable suspend/resume and reboot was successfull.

  • BeerBattery? is now installed by default and is working with the new ACPI.
  • Suspend does NOT work, the picture of the screen goes away, I get

funny colors on the screen, the "moon" begins to flash. That's all, I have to switch of the system after that to be able to restart!

[skipped]

comment:7 Changed 11 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.15

comment:8 Changed 11 years ago by pasha

  • Owner changed from pasha to acpi-admin

comment:9 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Release version 3.16
  • Owner acpi-admin deleted

comment:10 Changed 10 years ago by eco

From: Thorolf

ACPI: 3.16 (2009/05/29 ??)

I tested the 3.16 on my T60 with RC7pre, power off works but suspend/resume not.

See attached logs and screen-shots.

BTW: Is there a reason why in the ACPI-package there is only the debug version? That means that I don't use it on my working system to test the "general" stability!

Changed 10 years ago by eco

Changed 10 years ago by eco

Changed 10 years ago by eco

Changed 10 years ago by eco

Changed 10 years ago by eco

Changed 10 years ago by eco

comment:11 Changed 10 years ago by ecsnl

The naming convention is wrong of the ZIP file. This was a test build that was released. Tomorrow I hope to get back to help out with Chuck McKinnis? to get Warin packages released ASAP for ACPI.

For ACPI 3.15 and 3.16 take a look at ticket 412,413,414 and 415. Been collecting data and putting that in today. These problems are possibly caused by the updates done to the embedded controller code in ACPI ? Also ACPI 3.16 has C2 CPU state (is was there, don't remember the details Pasha can explain that).

I also have a T60.

Roderick

comment:12 Changed 10 years ago by eco

e-co:

Thorolf reports:

At Betazone the latest one is "acpifu-20090624.wpi" and is the one I have installed - suspend/resume does _not_ work!

And you also might check my acpi-settings (s/r with pressing shortly the power-button):

[ACPID]
LID = None
PowerButton = Suspend
SleepState = S3
LogFile = AcpiDaemon.log
IdleState = C2
MaxThrl = 0
MinThrl = 0
LogScreen = 0
ExtraKernelHLT = Yes
HLTTime = 700
VBESave = 7

Kernel is:
Signature:       @#IBM:14.104b#@_SMP  IBM OS/2 Kernel
Vendor:          IBM
Revision:        14.104
File Version:    14.104
Description:     _SMP  IBM OS/2 Kernel

comment:13 Changed 10 years ago by eco

Thorolf said some days ago:

can you post the report the acpi bug-tracker?

I forwarded the last answer from you according my last test's with s/r on my T60. It also does not work with the RC7pre-build from about mid of July - no idea which ACPI is included.

It does _not_ work on my T60 with the ACPI-drivers available until mid of July, the last version that worked partly might be 2 years old (s.th. around version 3.0.3).

You also might have a look on the feedback wizard, after most installation I submit the result and add some comment!

comment:14 Changed 8 years ago by dazarewicz

  • Keywords Suspend added

comment:15 Changed 7 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending

Please try the current version.

comment:16 Changed 7 years ago by dazarewicz

  • Resolution set to unknown
  • Status changed from new to closed

No response from reporter. Ticket is for an old version.

Note: See TracTickets for help on using tickets.