Opened 11 years ago

Closed 11 years ago

#236 closed defect (fixed)

FaxWorks works with OS2APIC, doesn't with ACPI

Reported by: eco Owned by: pasha
Priority: major Milestone:
Component: ACPI PSD Version: 3.08
Keywords: Cc:

Description

Pasha I still sometimes get the impression there are a few small things wrong in the SMP support we have in the PSD.

I'm trying to understand. What is the difference for the application when it comes to SMP provided via os2apic.psd or ACPI.PSD ? User G.S. has machine (Athlon X2) on which faxworks in SMP mode with OS2APIC. But does not work with ACPI.PSD in SMP mode. What kind of data do you need to debug this ?

Pasha:

What is chipset? If not ATI(AMD) - debug log from comport. For fisrt - log from boot w/o SMP.

e-co:

  • ACPI.PSD, do you use PIC or APIC?
  • What is the problem with Faxworks? Faxworks is starting? Are there troubles with transfer via COM-port?

Change History (3)

comment:1 Changed 11 years ago by yoda

It is _very_ long time ago, since I used FaxWorks?, but IIRC it installs its own device driver to talk to modem. This driver is most likely not APIC aware (as lots of other old drivers).

comment:2 Changed 11 years ago by guest

I have no problem with Faxworks in APIC mode. I do use PSCOM.SYS, however.

-Mike

comment:3 Changed 11 years ago by eco

  • Resolution set to fixed
  • Status changed from new to closed

OK, I added info about faxworks to ACPI docs -> troubleshooting

Note: See TracTickets for help on using tickets.