Opened 11 years ago

Closed 11 years ago

#175 closed defect (fixed)

rwklein

Reported by: guest Owned by: pasha
Priority: critical Milestone:
Component: ACPI PSD Version: 3.05
Keywords: Cc:

Description

Thinkpad T60p

When ACPI 3.05 is loaded it traps (trap 0008 after the last device driver is loaded (some kind of init switch state in the kernel). Disable /SMP /APIC and the trap goes away. Turns out it happens when speedstep in the BIOS is switched off. Turn it on and machine can load with /SMP /APIC. Not loading APM.ADD, still the machine traps.

Will post logs later.

Roderick Klein

Change History (13)

comment:1 Changed 11 years ago by guest

That's basically the same problem I have with my Athlon 64 X2 seen Ticket #168 (Trap 0008 after EVFS and before the GUI should be loaded; the other guy who started the ticket has a Trap 000c but seems to be the same position after EVFS driver and before GUI).
Interesting! I still offer the Null-Modem Bug-Hunting procedure. :)

Kind regards,
Juergen Ulbts

comment:2 Changed 11 years ago by pasha

If have ntfs.ifs and fat32.ifs try remming this ifs=. Also, interesting log from debug version acpi to comport, see /Ox option for acpi.psd

comment:3 Changed 11 years ago by eco

thy this:

Run ACPIDAEMON from x:\startup.cmd or StartUp? folder

add to x:\startup.cmd

x:\OS2\ACPIDAEMON.EXE

comment:4 follow-up: Changed 11 years ago by guest

Ok added output received via Null-Modem cable at BugId? #168. Removed ACPIDAEMON from Config.sys ...no change

So far I didn't remove FAT32 and NTFS.IFS.

comment:5 Changed 11 years ago by guest

Something similar happens here on a hp workstation x4000, dual xeon prestonia cpu. After an installation from the scratch for testing purposes of rc4 several traps began after evfs.ifs. After a complete reinstall the problem wasn't reproduceable anymore. I had opened a respective ticket on the ecs bugtracker with all logfiles, but afaics it doesn't yet appear in the ticket list.

Harald Kamm

comment:6 in reply to: ↑ 4 Changed 11 years ago by pasha

Replying to guest:

Ok added output received via Null-Modem cable at BugId? #168. Removed ACPIDAEMON from Config.sys ...no change

So far I didn't remove FAT32 and NTFS.IFS.

#168 about another computer, can you attach log from T60p ?

comment:7 Changed 11 years ago by eco

Hello Roderick

This is very important problem. Please collect logs.

comment:8 Changed 11 years ago by eco

Please download experimental ACPI build from Mensys site:

comment:9 Changed 11 years ago by eco

  • Resolution set to invalid
  • Status changed from new to closed

OK, it's impossible research the problem without logs, please re-open ticket if you have the notebook for testing.

comment:10 Changed 11 years ago by guest

  • Resolution invalid deleted
  • Status changed from closed to reopened

What is achieved by closing this ticket ? You close it and you loose track of the fact that the ticket was opened, I still need to supply logs that is true. In eComStatio bugtracker we also have many bugs open.

comment:11 Changed 11 years ago by guest

As an extra comment, we have some bugs open because lack of time to anlyse some of the bugs but others are open because they are moved to a next version of eCS.

comment:12 Changed 11 years ago by eco

Pasha recommends try to boot with new OS2LDR (it doesn't enable APM in the first moment) http://hobbes.nmsu.edu/cgi-bin/h-search?key=os2ldr&pushbutton=Search

Only to check, if this IBM os2ldr behaviour brings troubles

comment:13 Changed 11 years ago by eco

  • Resolution set to fixed
  • Status changed from reopened to closed

e-co: I added how to setup the model of notebook to ACPI documentation. This problem is specific to this notebook. So, the problem is "solved"

Note: See TracTickets for help on using tickets.