Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#155 closed defect (No Change Needed)

SMP and ACPI trashed volume

Reported by: guest Owned by: pasha
Priority: critical Milestone:
Component: ACPI PSD Version: 3.03
Keywords: Cc:

Description

I installed eCS 2.0 RC3 on my old Tyan dual PIII system with an on board LSI dual channel SCSI controller (SYM_HI.ADD). Used HPFS for the volume.

I then installed the SMP kernel and PSD=OS2APIC.PSD. Decided to test ACPI.PSD /SMP /PIC, even though I knew the documentation stated there were issues with ACPI and the SYM_HI.ADD driver. The boot got though to the Sci-Tech splash screen and hung without opening the desktop. I booted back to my old 1.2 volume and replaced the ACPI.PSD with the old OS2APIC.PSD. Tried to boot back to 2.0 and got the nasty "Unable to operate your hard drive" message. Reset and went back to 1.2. Ran DFSee. The messages are pretty nasty.

DFSee  OS/2  9.02 : Executing: vol F:
Command timestamp : Sunday 2007-11-11 16:59:03
Attempt to open   : F:
Volume type, attr : 5, 0x05 = Fixed disk (partition)

L-Geo Vol F: Cyl :267350 H:255 S:63  Bps:512   Size : 0x000028D6 =     5.1 MiB
Volume info on    : F:           Not ready, no size info, fs: HPFS
Error  25 seeking : 0x00000010 for read - Store 1 : Volume, drive-letter F: HPFS   size:    5.1 MiB
Error reading the HPFS Super-block from disk, possible bad-sector!

No valid HPFS Super-block found, using defaults

Error  25 seeking : 0x00000014 for read - Store 1 : Volume, drive-letter F: HPFS   size:    5.1 MiB

Errors getting bitmap-tables, allocation information unreliable!
Error  25 seeking : 0x00000011 for read - Store 1 : Volume, drive-letter F: HPFS   size:    5.1 MiB
Error reading the HPFS Spare-block from disk, possible bad-sector!

No valid HPFS Spare-block found, using defaults

Errors getting codepage-tables, codepage information unreliable!

Msg: 25    = 0x19 : Seek error at sector 0xffffffff
Volume, drive-letter F: HPFS   size:    5.1 MiB

ReadWrite Store 1 : Volume : F:                    mode=HPFS      111107-165904
RC:25    = 0x19   : 00000000 u=00000000 x=043D338A this=00000000  Base=00000000

I can understand the ACPI.PSD and SYM_HI.ADD issue, but I don't understand why the volume would be trashed.

I am back running eCS 2.0 RC3 w/SMP (OS2APIC.PSD) on JFS, and all is well.

Chuck McKinnis?
mckinnis@…

Change History (5)

comment:1 follow-up: Changed 6 years ago by eco

OK, I have seen ~ 5 similar reports.

Remind me please, how do you reboot after install/de-install of ACPI.PSD? Using CAD? or using Reset?

comment:2 in reply to: ↑ 1 Changed 6 years ago by guest

Replying to eco:

OK, I have seen ~ 5 similar reports.

Remind me please, how do you reboot after install/de-install of ACPI.PSD? Using CAD? or using Reset?

Pretty simple. After the install, I select Shutdown and Reboot.

There is no de-install. The volume is toast.

Chuck McKinnis?

comment:3 Changed 6 years ago by pasha

  • Status changed from new to assigned

Need try boot with /!NOD. If fail - I need in acpi,log

comment:4 Changed 6 years ago by guest

  • Resolution set to invalid
  • Status changed from assigned to closed

OK, We understand that the problem is very terrible. ACPI can't cause such troubles.

System shutdown may cause this. We are going update documents and installer. and ask users make backups before testing ACPI.PSD, use tested WarpIn?, use Ctrl -Alt-Del for reboot.

comment:5 Changed 6 years ago by guest

I think I have discovered the problem.

The bootable JFS code was installed, but the JFS utility modules (including EXTENDFS.EXE) are not up to date. They do not match either the latest bootable JFS code or the code shipped by IBM in JFS14105.

Joachim and Eugene are aware of the issue.

Chuck McKinnis?
mckinnis@…

Note: See TracTickets for help on using tickets.