Opened 7 years ago

Closed 7 years ago

#130 closed defect (fixed)

ACPI v3.03 TrapE with SMP

Reported by: guest Owned by: pasha
Priority: major Milestone:
Component: ACPI PSD Version: 3.03
Keywords: Cc:

Description

IBM ZPro 6221 gives TRAP E when WPS is starting and /SMP switch is present in config.sys. However, if system booted with acpi.psd and no /SMP option then boot is ok and power off works. System did work with 3.02 and SMP but would not complete power off. Acpi.log attached from 3.03 running single CPU.

Attachments (1)

acpi_singlecpu.log (11.5 KB) - added by guest 7 years ago.
acpi.log

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by guest

acpi.log

comment:1 Changed 7 years ago by guest

Requested IBM506 log:

R1.8.1a

Daniela's Bus Master IDE Driver for OS/2 Version 1.8.1a

Controller:0 Port:01F0 IRQ:0E Status:OK BusMaster? Scatter/Gather?

Intel ICH4 PATA host (8086:24CB rev:02) on PCI 0:31.1#0

Unit:0 Status:OK SMS:16 LBA BusMaster? UltraDMA5/PIO4 BPB

Model:MAXTOR STM3320620A

OS2:log phys BPB/BIOS IDE:log phys Total Sectors

C 38913 65535 65535 16383 Avail 625142448
H 255 16 255 16 16 OS2 625137345
S 63 63 63 63 63 % Used 99.99

Controller:1 Port:0170 IRQ:0F Status:OK BusMaster? Scatter/Gather?

Intel ICH4 PATA host (8086:24CB rev:02) on PCI 0:31.1#1

Unit:0 Status:OK ATAPI BusMaster? UltraDMA2/PIO4

Model:DVDRW IDE 16X VER A091

comment:2 Changed 7 years ago by guest

TRy again:

R1.8.1a     
            Daniela's Bus Master IDE Driver for OS/2 Version 1.8.1a
Controller:0  Port:01F0 IRQ:0E  Status:OK BusMaster Scatter/Gather
  Intel ICH4 PATA host (8086:24CB rev:02) on PCI 0:31.1#0
 Unit:0 Status:OK SMS:16 LBA BusMaster UltraDMA5/PIO4 BPB
  Model:MAXTOR STM3320620A    
   OS2:log   phys   BPB/BIOS   IDE:log   phys     Total Sectors
  C  38913  65535                65535  16383   Avail  625142448
  H    255     16        255        16     16   OS2    625137345
  S     63     63         63        63     63   % Used     99.99
Controller:1  Port:0170 IRQ:0F  Status:OK BusMaster Scatter/Gather
  Intel ICH4 PATA host (8086:24CB rev:02) on PCI 0:31.1#1
 Unit:0 Status:OK ATAPI BusMaster UltraDMA2/PIO4
  Model:DVDRW IDE 16X                           VER A091

rmview /irq output

RMVIEW: Physical view
  IRQ Level =  0  PCI Pin = NONE  Flg = EXCLUSIVE    TIMER_CH_0
  IRQ Level =  1  PCI Pin = NONE  Flg = EXCLUSIVE    KBD_0 Keyboard Controller
  IRQ Level =  2  PCI Pin = NONE  Flg = EXCLUSIVE    PIC_1
  IRQ Level =  3  PCI Pin = NONE  Flg = MULTIPLEXED  SERIAL_1  Serial Controller
  IRQ Level =  4  PCI Pin = NONE  Flg = MULTIPLEXED  SERIAL_0  Serial Controller
  IRQ Level =  5  PCI Pin = NONE  Flg = SHARED       Intel 82801DB-ICH4 with Analog Devices AD1885
  IRQ Level =  6  PCI Pin = NONE  Flg = MULTIPLEXED  FLOPPY_0 Floppy Controller
  IRQ Level =  8  PCI Pin = NONE  Flg = EXCLUSIVE    RTC
  IRQ Level =  9  PCI Pin = NONE  Flg = SHARED       ACPI Interface
  IRQ Level = 12  PCI Pin = NONE  Flg = EXCLUSIVE    AUX_0 PS/2 Auxiliary Device Controller
  IRQ Level = 14  PCI Pin = NONE  Flg = EXCLUSIVE    IDE_0 xATA Controller
  IRQ Level = 15  PCI Pin = NONE  Flg = EXCLUSIVE    IDE_1 xATA Controller


comment:3 Changed 7 years ago by greenemk

Fixed version of acpi provided by Pasha on 20 Oct 07 fixes all problems.

comment:4 Changed 7 years ago by eco

  • Resolution set to fixed
  • Status changed from new to closed

User confirmed that the problem is resolved. Wait for public release of ACPI 3.05.

Note: See TracTickets for help on using tickets.