Opened 7 years ago

#10 new defect

APM setting is forgotten after resume

Reported by: lewisr Owned by: stevenhl
Priority: minor Milestone: Release-1.8.16
Component: danis506.add Version: 1.8.9
Keywords: apm noise spindown resume suspend power Cc:

Description

Background:

Replaced ThinkPad? T43 internal drive with a Western Digital 320GB 5400 RPM Scorpio Blue (WD3200BEVT). These new "green" hard drives spin down quickly, locking the heads, which results in an audible (and annoying) "click!"

DaniS506.DOC refers to /APM switch, and provides basic guidelines for setting the /APM:n value. 254 is the *lowest* acceptable value (vs 255, which switches off the circuit, entirely) providing for quiet operation (at the expense of some battery power). (See http://www.2rosenthals.net/wordpress/the-telltale-hard-drive-173/ for more background, if necessary.)

Problem:

System boots and runs fine. System suspends without incident (APM.SYS is at 10.156 level; no ACPI on this machine). Upon resume, drive reverts to default behavior, of clicking every 8 or 9 seconds.

Expected behavior:

Just as Dani queries the removable bays for changes upon resume (in case of a warm swap), Dani should query/reset the non-removables upon resume, so that the boot time configuration is preserved.

Dani details, disk info, etc.:

See attachment.

CONFIG.SYS:

BASEDEV=DANIS506.ADD /VL /GBM /A:0 /U:0 /APM:254 /A:1 /BAY /A:2 /BAY /A:3 /PCS

Attachments (1)

apm_lost_after_suspend.zip (5.6 KB) - added by lewisr 7 years ago.
Collected query files (bldlevel, debug, DiskInfo?, etc.)

Download all attachments as: .zip

Change History (1)

Changed 7 years ago by lewisr

Collected query files (bldlevel, debug, DiskInfo?, etc.)

Note: See TracTickets for help on using tickets.