Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#37 closed defect (fixed)

UniAud stopped producing sound on SB Live after 114rc1

Reported by: stevew@… Owned by: gentux2
Priority: normal Milestone: Stabilization
Component: UNIAUD32 Version: 1.1.4
Severity: normal Keywords:
Cc:

Description

NULL pointer dereference in sound/synth/emux/soundfont.c

It seems unlikely that this is the cause, but my SB Live is now silent: 6-23-06 11:26a 579690 54 uniaud32.sys 7-09-06 10:27a 585051 54 uniaud32.sys.bad

Attachments (9)

uniaud-good.log (9.6 KB) - added by stevew@… 13 years ago.
alsahlp$ from working driver
uniaud-bad.log (18.6 KB) - added by stevew@… 13 years ago.
alsahlp$ from failing driver
uniaud-bad.2.log (14.1 KB) - added by stevew@… 13 years ago.
log from 9/10 build of uniaud32
uniaud32.log (20.7 KB) - added by guest 13 years ago.
log from version 114rc2 (still silent)
uniaud.log (23.3 KB) - added by guest 12 years ago.
alsahlp$ from 1/28/2007 testcase
alsahlp-dbg.log (24.0 KB) - added by gentux2 12 years ago.
alsahlp$ for debug uniaud32 1.1.4RC3, from Steve Wendt
uniaud.2.log (11.7 KB) - added by gentux2 12 years ago.
1.1.4RC3 Release alsahlp$, from Craig Colby
PCI.txt (834 bytes) - added by gentux2 12 years ago.
PCI info for SB Live device affected, from Steve Wendt
debuginfo.zip (8.9 KB) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (17)

Changed 13 years ago by stevew@…

alsahlp$ from working driver

Changed 13 years ago by stevew@…

alsahlp$ from failing driver

Changed 13 years ago by stevew@…

log from 9/10 build of uniaud32

comment:1 Changed 13 years ago by stevew@…

With the latest (still failing) version, I hear a pop from the speakers when the driver loads during boot.

comment:2 Changed 13 years ago by vladest

  • Status changed from new to assigned

mine too

Changed 13 years ago by guest

log from version 114rc2 (still silent)

comment:3 Changed 12 years ago by guest

Seems to be working again with latest:
12-04-06 1:07p 61210 0 uniaud16.sys

1-25-07 8:55a 610182 54 uniaud32.sys

However, it looks like there are constant fixups happening:
Device is not in proper state: 1. Calling prepare

Changed 12 years ago by guest

alsahlp$ from 1/28/2007 testcase

comment:4 Changed 12 years ago by gentux2

  • Milestone set to 1.1.5
  • Owner vladest deleted
  • Status changed from assigned to new
  • Version set to 1.1.4

Steve Wendt reports on uniaud-dev, and Craig Colby asked me privately to report, that 1.1.4RC3 still does not work with the SB Live (1102:0002). I am attaching the debug log from Steve and the release log from Craig. Both have the same device so I am only attaching the PCI info from Steve. Both confirmed that uniaud32 1.1.4RC1 works fine.

Changed 12 years ago by gentux2

alsahlp$ for debug uniaud32 1.1.4RC3, from Steve Wendt

Changed 12 years ago by gentux2

1.1.4RC3 Release alsahlp$, from Craig Colby

Changed 12 years ago by gentux2

PCI info for SB Live device affected, from Steve Wendt

Changed 12 years ago by guest

comment:5 Changed 12 years ago by guest

  • Summary changed from UniAud testcase no longer produces sound on SB Live to UniAud stopped producing sound on SB Live after 114rc1

With Uni32ReSync-0.9.7, I still get a pop from the speakers during boot, followed by silence once PM loads.

comment:6 Changed 11 years ago by gentux2

  • Owner set to gentux2
  • Status changed from new to assigned

The breakage occurs in changeset:77 in /alsa-kernel/pci/ac97/ac97_codec.c

comment:7 Changed 11 years ago by gentux2

  • Resolution set to fixed
  • Status changed from assigned to closed

Reverted the offending change in Changeset:283. SB Live now has sound with latest trunk. It can be put back if someone figures out why it broke and how to fix it Otherwise we'll face it again in the ReSync?, or else it will sort itself out in the process.

comment:8 Changed 11 years ago by gentux2

Link didn't work. Make that: changeset:283

Note: See TracTickets for help on using tickets.