Opened 12 years ago

Closed 10 years ago

#145 closed defect (fixed)

Repeated sound with HDA ICH7 + ALC662 (buffer problem?)

Reported by: djcaetano Owned by: David Azarewicz
Priority: normal Milestone: HDA
Component: UNIAUD32 Version: 1.9.8
Severity: major Keywords:
Cc:

Description

I am using eCS RC4 and a Core2 Quad machine (Gigabyte GA-G31M-S2L motherboard, running on SMP mode and ACPI 3.10). I was using a mixed configuration (UNIAUD16 from 1.1.4RC6 + UNIAUD32 from 1.1.4RC2) which works somewhat (sometimes the system simply hangs, but overall it works). Every release of UNIAUD since 1.9.3 had no sound at all (1.9.2 caused repeating sounds, buffer problem I believe - instead of "tadam!" I get a "tadtadtadtadtad...") and I decided to give a try on 1.9.8 (both Uniaud16 and 32). The result was the same as 1.9.2, but since there is sound, it is a huge step forward from 1.9.3~1.9.7.

Now I am using 1.9.8 Uniaud16 combined with 1.1.4RC2 Uniaud32 and the result is better than previous combinations. The problem seems to be on UniAud32. I am attaching the debug info for the problematic 1.1.8 config. Also added the data generated by UniInfo? for the combination 1.9.8/1.1.4RC2, but this one was got with release version of the drivers. Let me know if a full-debug of this combination is needed so I can locate the RC2 debug drivers.

Attachments (2)

debuginfo_118.zip (7.7 KB) - added by djcaetano 12 years ago.
Debug Info (UniInfo?) for UniAud? 1.9.8 debug
debuginfo_16-118_and_32-114rc2.zip (6.2 KB) - added by djcaetano 12 years ago.
Debug Info (UniInfo?) for UniAud16 1.9.8 + UniAud32 1.1.4RC2 (both release)

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by djcaetano

Attachment: debuginfo_118.zip added

Debug Info (UniInfo?) for UniAud? 1.9.8 debug

Changed 12 years ago by djcaetano

Debug Info (UniInfo?) for UniAud16 1.9.8 + UniAud32 1.1.4RC2 (both release)

comment:1 Changed 11 years ago by Paul Smedley

Can you please try with the latest v1.9.12 build from http://svn.netlabs.org/uniaud

comment:2 Changed 10 years ago by David Azarewicz

Owner: set to David Azarewicz
Status: newassigned

Test the latest BETA build. I believe all traps, hangs, and buffer problems have been fixed.

comment:3 Changed 10 years ago by David Azarewicz

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.