Opened 11 years ago

#138 new defect

Linux version is 2.3.0

Reported by: gentux2 Owned by:
Priority: high Milestone: ALSA Hardware Compatibility
Component: UNIAUD32 Version: 1.1.4RC6
Severity: critical Keywords:
Cc:

Description

When ALSA compiles, it includes different code depending on which version of Linux is reported. At present in Uniaud this is 2.3.0, which, we can be sure, is untested with the latest ALSA code. This could be a source of some problems on the new hardware.

Setting the value to 2.6.0 causes the compile to fail, so clearly there is some work needed to update the Linux code. It should be a matter of setting this and finding the relevant bits in Linux and porting it.

One thing to check with this is the macro used to figure the version number in Uniaud uses a bit shift, whereas I have the distinct impression that Linux uses a direct decimal conversion. So the numbers might only work out the same when all digits are low enough. Just something to verify at the same time this is done.

Change History (0)

Note: See TracTickets for help on using tickets.