Opened 12 years ago

Closed 3 months ago

#134 closed task (fixed)

Lars' Installer

Reported by: Brendan Oakley Owned by:
Priority: normal Milestone: Open Tools, etc.
Component: installer Version: 1.1.4RC6
Severity: normal Keywords:
Cc:

Description

Lars Erdmann wrote a replacement installer for Uniaud. It, and its source, are in a package on Hobbes. It is an improvement over the existing one in that it provides a reliable uninstall. Additionally, he has made the source freely distributable. Mike Greene created makefiles so that it builds with OpenWatcom.

The problem is that the new minstall in eComStation does not support all of the API's used by this installer, so ironically it only works in Warp 4 at present, until minstall is fixed to support it.

The new minstall source is available here: http://svn.netlabs.org/minstall/browser

Change History (3)

comment:1 Changed 12 years ago by Brendan Oakley

I am in favor of moving to this installer. IIRC it is written in C, which I think makes it a little nicer than the old one in RC. It's code we can expose, so more eyes can look at it. It is an improvement, and I think it's worth recognizing that Lars went to the work to do it.

It's ironic that the new open source installer requires the old, unsupported minstall. I don't have time at the moment to look at fixing minstall, but what I will do is get this installer's source into svn, and well as Mike's OW makefiles, so it's part of the project. Requiring an improvement to minstall is a good thing, we should want it to be better.

If no-one else looks at this, I will, but only after the resync and my other commitments here.

comment:2 Changed 3 months ago by martini

Hi

As far as I know the latest Uniaud verion use the WarpIn? installer and not minstall. I think it is safe to close this ticket.

Since this ticket it is too old, in case of problems with the installer please try the latest version and reopen the ticket.

Regards

comment:3 Changed 3 months ago by martini

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.