Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1 closed (fixed)

Setting initial focus to a widget control fails for [OK] and [Cancel] buttons

Reported by: jvw Owned by: anonymous
Priority: normal Milestone: milestone1
Component: component1 Version: 1.0
Severity: normal Keywords: widget focus
Cc:

Description

Settuing initial focus is done by specifying the INDEX to the widget that needs to get the initial focus at dialog creation. This fails for standard bottons like[OK]

Change History (9)

comment:1 Changed 13 years ago by anonymous

  • Owner changed from jvw to anonymous
  • Status changed from new to assigned

comment:2 Changed 13 years ago by jvw

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 13 years ago by jvw

Problem was caused by thios buttons having different Window-IDs. Other widgets have base+index, while these have fixed DID_OK and DID_CANCEL This needs to be checked when setting focus at dialog creation. If the 'explicit' window-ID in the widget is non-zero, that must be used as target windows-ID, not the calculated base+index value.

Fixed in changeset 6

comment:4 Changed 13 years ago by jvw

  • Version set to 1.0

comment:5 Changed 12 years ago by kkkkoaaa

Keep a good job up! http://quick-adult-links.com

Note: See TracTickets for help on using tickets.