Opened 10 years ago

Closed 10 years ago

#86 closed defect (fixed)

IO errors during writes

Reported by: digi Owned by: diver
Priority: major Milestone: Netdrive plugin 1.5.0
Component: Samba Client Plugin Version: NDP 1.5 alpha
Keywords: Cc:

Description

Samba continues to try to write a file if is an any errors happens during recording. Some times file stay opened after user's logout until samba runned.

It may be reproduced with my program bladder.exe. Bladder.exe can create file with specified size for reducing free space on drive. Also plugin NDPLQ for NetDrive? can be used. Debug version of this plugin will show perpetual writes with errors.

Attachments (4)

ndplq-20090429.zip (51.7 KB) - added by digi 10 years ago.
NetDrive? plugin. NDPLQ allows to access local volumes/dirictoyes with quotas.
bladder.zip (10.5 KB) - added by digi 10 years ago.
smb-log-disk_full-level3.zip (47.1 KB) - added by digi 10 years ago.
"disk full" error (log level = 3)
smb-log-disk_full-level8.zip (135.0 KB) - added by digi 10 years ago.
"disk full" error (log level = 8)

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by digi

NetDrive? plugin. NDPLQ allows to access local volumes/dirictoyes with quotas.

Changed 10 years ago by digi

comment:1 Changed 10 years ago by digi

  • Version set to 3.0.25pre1-20070302

comment:2 Changed 10 years ago by digi

  • Milestone set to Samba Server for eCS (OS/2) 1.0.2
  • Version 3.0.25pre1-20070302 deleted

comment:3 Changed 10 years ago by digi

  • Milestone changed from Samba Server for eCS (OS/2) 1.0.2 to Samba Server for eCS (OS/2) 1.1

comment:4 Changed 10 years ago by diver

  • Milestone changed from Samba Server for eCS (OS/2) 1.1 to Samba Server for eCS (OS/2) 1.0.2

could you produce a samba log with loglevel 5 and attach it here

Changed 10 years ago by digi

"disk full" error (log level = 3)

Changed 10 years ago by digi

"disk full" error (log level = 8)

comment:5 Changed 10 years ago by digi

Last full functional version of netdrive LQ plugin: ftp://digi.os2.snc.ru/pub/dev/ndplq-20090503.zip

comment:6 Changed 10 years ago by digi

  • Component changed from Server to Client
  • Milestone changed from Samba Server for eCS (OS/2) 1.0.2 to Netdrive SMB Client plugin 1.5.0
  • Owner psmedley deleted
  • Priority changed from blocker to major

Hm, I cannot reproduce this problem with win-client (but I was shure I tested it...). It happen only with OS/2-client.

Sorry, I change "Milestone" of ticket to Netdrive SMB Client plugin.

comment:7 Changed 10 years ago by diver

  • Owner set to diver
  • Version set to Netdrive SMB Client plugin 1.5 alpha 1

comment:8 Changed 10 years ago by diver

  • Resolution set to worksforme
  • Status changed from new to closed

Digi, which version of ndpsmb do you use? we can't reproduce it with 1.5 alpha client

comment:9 Changed 10 years ago by diver

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:10 Changed 10 years ago by digi

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.