Opened 20 months ago

Last modified 19 months ago

#321 accepted defect

Mouting directort with many files in it renders OS/2 system useless

Reported by: ecsnl Owned by: psmedley
Priority: minor Milestone:
Component: Unknown Version: Client 3.0.x
Keywords: Cc: ecsnl

Description

Running some tests I creates one directory with 250000 files on a Linux Samba server. These are normal 0 byte files (nothing special). They where created on the Linux box with a script. Filename 1 to 249999 created).

If I use the IBM Network Requester (netbios over TCP/I) to connect to the share and do run the DIR command from 4OS/2 or CMD.EXE session the system continues to work.

When with ArcaOS 5.02 freshly installed system I mount that share and run the DIR command the system is toast. What happens it seems is that all lower shared memory gets consumed. Freesharedmem reports this as well then it runs down to 0 free memory. The system in total has 1 GB of RAM. In 4OS2 when I run the DIR command, this output follows:

SYS0008: There is not enough memory available to process this command. All available memory is in use.

27.011.223.552 bytes (25GB) free

The same occurs when I run the DIR command from CMD.EXE. With in seconds freesharedmem.exe drops to 0 bytes. And when you try to start any other program you get a SYS0008.

The Xworkplace memory watcher reports that the amount of memory has dropped from 892 MB free down to 596 MB free. So 296 MB of RAM has been consumed by the DIR command.

Note this is a freshly installed system and this DIR is done after I mounted this network share with ArcaMapper?.

Change History (6)

comment:1 Changed 20 months ago by ecsnl

  • Cc ecsnl added

Ticket opened by Roderick Klein.

Samba Client Versions: File system NDFS32 Version 3.028 Plugin file H:\PROGRAMS\NDFS\NDPLUGS\NDPSMB.DLL Plugin Vendor netlabs Plugin Revision 3.00.x Plugin Date/Time? 9 Jun 2017 14:55:34 Plugin Build Machine ARCAOS-D0C2 Plugin Language Code en Plugin File Version 3.0 Plugin Description NDPSMB - SMBFS NetDrive? External Plugin Build beta-date Commandline utilities Version 3.3.16-eCS 1.1.4-804 options.!appname_long Version 2.6.20180125

comment:2 Changed 20 months ago by ecsnl

I added the the settings to SMB.CONF, made no difference: read raw = Yes socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=131072 SO_SNDBUF=131072 min receivefile size = 16384 The memory leak still occurs and no more programs can be started. The memory is also never released if unmount the share, close cmd.exe or kill the deamon of Netdrive.

comment:3 Changed 20 months ago by psmedley

Hi Roderick, can you share the script you used on the linux server to create the test files? log files would also be useful, but me being able to reproduce locally would be the best.

Given that the memory doesn't get released bu closing ndctl, I'd suggest libcx or libc066 aren't releasing the memory.

comment:4 Changed 20 months ago by psmedley

  • Owner set to psmedley
  • Status changed from new to accepted

comment:5 Changed 20 months ago by diver

try also the 2.x series of the plugin. In theory you should see the same there as well. But you never know

comment:6 Changed 19 months ago by psmedley

OK I can reproduce the SYS0008 here with a folder with 250k files in it

Note: See TracTickets for help on using tickets.