Opened 3 years ago

Closed 3 years ago

#314 closed defect (fixed)

Samba Server 1.3.0 Install Problem

Reported by: WAS2013 Owned by:
Priority: major Milestone:
Component: Samba Server WarpIN archive Version: Server 3.6.x
Keywords: Cc:

Description

After successfully installing ArcaOS, I first installed <rxlib4smb.wpi>. I also checked the other required libraries, using the yum install libc libcx libgcc1 cups-libs popt-libs gettext-libs zlib readline command, and it was indicated they were all installed.

I then tried installing <samba-1-3-0-1022.wpi>. Unfortunately it complained it couldn't find the following Runtime Libraries:

READLN6 Chris Wohlgemuth's Dave Boll's

I went back to the first file and reinstalled what seemed to be just the 2nd and 3rd packages, but that didn't seem to correct that problem. Using ANPM I installed the Readline 6.1-4 libraries but that didn't correct the 1st problem either; maybe though these are different from READLN6.

Any ideas? I guess I could post in <mantis.arcanoae.com> but this doesn't seem an ArcaOS problem.

Change History (3)

comment:1 Changed 3 years ago by dwparsons

Yes, I found this yesterday. Although it says it is looking for READLN6, it actually searches for READLN6L.DLL. Typo in the wpi script.

Dave

comment:2 Changed 3 years ago by WAS2013

Well maybe for general installation, this will be a necessary revision.

For installation under ArcaOS, there is already an option under Selective Install for Networking for installation of the Samba Server. I only just discovered the option as a result of a response by Neil Waldhauer to an inquiry I made to him.

So from the immediate standpoint of my issue, the problem is solved. How relevant this all is for general application, I'll let the experts decide.

comment:3 Changed 3 years ago by Herwig Bauernfeind

Resolution: fixed
Status: newclosed

This was fixed in changeset #1035

Note: See TracTickets for help on using tickets.