Opened 4 years ago

Closed 2 years ago

#254 closed defect (lack of feedback)

Suddenly wrong partitions

Reported by: agw Owned by:
Priority: Feedback Pending Milestone: Samba Client GUI (EVFSGUI) 2.x
Component: Samba Client GUI Version: Server 3.6.x
Keywords: Cc: herwig.bauernfeind@…

Description

I have installed WinXP, openSUSE 13.2 and eCS 2.1 DE on two computers. Networking between openSUSE and openSUSE or between WinXP and WinXP or between openSUSE and WinXP works fine. The old peer (with NetBIOS) for eCS and Win works too.

I have problems with Samba for eCS. Using "Einzelne Freigabe" it seems to be alright. But using "Alle Server in der Arbeitsgruppe" (what would be my preference) or "Alle Freigaben am Server", I get troubles between eCS and eCS or from eCS to Win (in this direction).

It is a little bit difficult to explain for me, especially in English: Opening a partition works, opening another partition may work, but suddenly - at any time - I cannot open a directory (it seems to be empty) or I cannot open a file, which worked seconds before. If I try again and again, it can work again - or not. If I press "F5" the complete contents of the partition changes, and I see the contents of another partition. This seems to be the last successfully opend partition. But the title of the window is still from the originally choosen partition.

Attachments (4)

Hilfe-Produktinfo_2.txt (441 bytes) - added by agw 4 years ago.
log_ndpsmb.zip (51.8 KB) - added by agw 4 years ago.
log_smbc.zip (186.6 KB) - added by agw 4 years ago.
progress.txt (524 bytes) - added by agw 4 years ago.

Download all attachments as: .zip

Change History (27)

comment:1 Changed 4 years ago by agw

  • Version set to Server 3.6.x

It is not possible to attach files!

comment:2 Changed 4 years ago by diver

  • Component changed from Unknown to Samba Client GUI (EVFSGUI)
  • Priority changed from critical to Feedback Pending

attaching files works, if they are not to large. So please try again.

comment:3 Changed 4 years ago by agw

It's definitive not possible to attach files. There's no chance to choose any file. If I click "Datei anhängen", I get the error message: Trac hat einen internen Fehler festgestellt: IndexError?: pop from empty list

I will attach the text here:

Installed modules
samba-1-1-4-804.wpi
evfsgui-213-GA-20120412.zip, on the second PC: evfsgui-25RC7-20141213.zip both as upgrade
ndpsmb-2_1_5-GA-20131003.wpi

comment:4 Changed 4 years ago by agw

Samba Client Versions:
File system EVFS Version 1.002
Plugin file I:\ecs\dll\ndpsmb.dll
Plugin Vendor bww bitwise works GmbH.
Plugin Revision 2.01.1.5
Plugin Date/Time? 3 Oct 2013 15:47:30
Plugin Build Machine ThinkCentre?
Plugin Language Code en
Plugin File Version 2.1
Plugin Description NDPSMB - SMBFS NetDrive? External Plugin Build GA-20131003
Plugin file I:\ecs\dll\InstallPackages?\ndpsmb\ndpsmb.dll
Plugin Vendor bww bitwise works GmbH.
Plugin Revision 2.01.1.5
Plugin Date/Time? 3 Oct 2013 15:47:30
Plugin Build Machine ThinkCentre?
Plugin Language Code en
Plugin File Version 2.1
Plugin Description NDPSMB - SMBFS NetDrive? External Plugin Build GA-20131003
Commandline utilities Version 3.0.37-eCS 1.0.6-565
EVFSGUIVersion 2.5.RC7-[2014-11-14]

comment:5 Changed 4 years ago by agw

log.nmbd

[2015/06/11 20:52:11, 0] nmbd/nmbd.c:main(870)

nmbd version 3.3.16-eCS 1.1.4-804 started. Copyright Andrew Tridgell and the Samba Team 1992-2009

[2015/06/11 20:52:11, 2] lib/tallocmsg.c:register_msg_pool_usage(106)

Registered MSG_REQ_POOL_USAGE

[2015/06/11 20:52:11, 2] lib/dmallocmsg.c:register_dmalloc_msgs(77)

Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED

[2015/06/11 20:52:11, 0] nmbd/nmbd.c:main(898)

standard input is not a socket, assuming -D option

[2015/06/11 20:52:11, 2] nmbd/nmbd.c:main(903)

Becoming a daemon.

[2015/06/11 20:52:11, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 20:52:11, 2] nmbd/nmbd_subnetdb.c:make_subnet(154)

making subnet name:192.168.178.67 Broadcast address:192.168.178.255 Subnet mask:255.255.255.0

[2015/06/11 20:52:11, 2] nmbd/nmbd_subnetdb.c:make_subnet(154)

making subnet name:UNICAST_SUBNET Broadcast address:0.0.0.0 Subnet mask:0.0.0.0

[2015/06/11 20:52:11, 2] nmbd/nmbd_subnetdb.c:make_subnet(154)

making subnet name:REMOTE_BROADCAST_SUBNET Broadcast address:0.0.0.0 Subnet mask:0.0.0.0

[2015/06/11 20:54:17, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 20:56:23, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 20:58:23, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 21:00:25, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 21:02:33, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 21:04:43, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 21:06:51, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 21:08:57, 2] lib/interface.c:add_interface(340)

added interface lan0 ip=192.168.178.67 bcast=192.168.178.255 netmask=255.255.255.0

[2015/06/11 21:10:16, 0] nmbd/nmbd.c:terminate(75)

Got SIGTERM: going down...

comment:6 Changed 4 years ago by agw

log.smbd

[2015/06/11 20:52:11, 0] smbd/server.c:main(1310)

Server priority set to PRTYC_FOREGROUNDSERVER

[2015/06/11 20:52:11, 0] smbd/server.c:main(1313)

smbd version 3.3.16-eCS 1.1.4-804 started. Copyright Andrew Tridgell and the Samba Team 1992-2009

[2015/06/11 20:52:11, 2] lib/tallocmsg.c:register_msg_pool_usage(106)

Registered MSG_REQ_POOL_USAGE

[2015/06/11 20:52:11, 2] lib/dmallocmsg.c:register_dmalloc_msgs(77)

Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED

comment:7 Changed 4 years ago by diver

  • Cc herwig.bauernfeind@… added

as this sound's like a client problem, I wonder why you attach server logs. I'm sorry but those show nothing about you particular problem.

comment:8 Changed 4 years ago by agw

I don't know. I am only a poor, little, silly user and my Samba is not working. These are my first adventures with this software.

If you tell me, what you need, and how I can get it, I will try to "attach" it here.

comment:9 Changed 4 years ago by agw

  • Priority changed from Feedback Pending to critical

comment:10 Changed 4 years ago by diver

  • Priority changed from critical to Feedback Pending

for eCS to Win you don't need a samba server. The client is enough. Please try to enable the logging in the client. How this is done is written in the client's help.

comment:11 Changed 4 years ago by herwigb

Please update your commandline utilities - yours are still based upon Samba 3.0.x which is outdated and unsupported. Get ftp://ftp.netlabs.org/pub/samba/client/smbclut/smbclut-1-1-4-804.zip

comment:12 Changed 4 years ago by agw

That took some time now.

In eCS 2.1 there is EVFS preinstalled and you can't change the installation path \ecs\SYSTEM\samba. Installing the server, the path \samba is given. I changed this to \SambaServer?, not to the above path. So I got the old files in \ecs\SYSTEM\samba, which were used, and the new files in \SambaServer?. This was the cause for the old version of the commandline utilities.

Now I deinstalled all Samba modules on both PCs and installed them again in only one path. So I have clean installations at present. And I use evfsgui-213-GA-20120412 now, because I had an error message each time I startet the client.

But the problems are the same!

I can't add log.ndpsmb (888 KB) and log.smbc (4,4 MB) as text here, they are too great.

comment:13 Changed 4 years ago by agw

Samba Client Versions:
File system EVFS Version 1.002
Plugin file I:\ecs\dll\ndpsmb.dll
Plugin Vendor bww bitwise works GmbH.
Plugin Revision 2.01.1.5
Plugin Date/Time? 3 Oct 2013 15:47:30
Plugin Build Machine ThinkCentre?
Plugin Language Code en
Plugin File Version 2.1
Plugin Description NDPSMB - SMBFS NetDrive? External Plugin Build GA-20131003
Commandline utilities Version 3.3.16-eCS 1.1.4-804
EVFSGUIVersion 2.1.3 [2011-09-13]

comment:14 Changed 4 years ago by agw

  • Priority changed from Feedback Pending to critical

Changed 4 years ago by agw

comment:15 Changed 4 years ago by agw

I changed my preferences of trac now. The language to English and the time zone to GMT, and suddenly I can attach files. But the file limit is 256 KB. I try to get less sizes.

Changed 4 years ago by agw

Changed 4 years ago by agw

Changed 4 years ago by agw

comment:16 Changed 4 years ago by agw

It would be nice to hear, if You need other informations from me. And if you see any chance to get rid of my error. Are you working on that problem?

I am waiting for your help.

Thank you!

comment:17 Changed 4 years ago by diver

We try to reproduce it one more time. Until now I personally failed to do so.

comment:18 Changed 4 years ago by diver

  • Milestone set to Samba Client GUI (EVFSGUI) 2.x
  • Priority changed from critical to major

comment:19 Changed 3 years ago by agw

Because of a lot of wrong networking files in eCS 2.1 german, I installed Samba on eCS 2.2 beta II. And this time I used NetDrive? 3.1.4, instead of EVFS. And I changed some release names, too. But I get the same errors.

comment:20 Changed 3 years ago by herwigb

Hello agw, sorry to say, but I have simply a problem understanding at all what is going at all on your side.

Please write me an email in german to herwig.bauernfeind@… and I will try to help you.

comment:21 Changed 3 years ago by herwigb

  • Resolution set to feedback pending
  • Status changed from new to closed

comment:22 Changed 3 years ago by diver

  • Priority changed from major to Feedback Pending
  • Resolution feedback pending deleted
  • Status changed from closed to reopened

comment:23 Changed 2 years ago by diver

  • Resolution set to lack of feedback
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.