Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#222 closed defect (fixed)

EVFSGUI fatal error 'E' at startup

Reported by: asavage Owned by: herwigb
Priority: minor Milestone: Samba Client GUI (EVFSGUI) 2.x
Component: Samba Client GUI Version: Samba Client GUI (EVFSGUI) 2.0
Keywords: Cc: steve53@…

Description

Upon a recent reboot, I saw this:

" Line 22 of _LoadOtherFuncs in evfsgui.VRM: +++ Call VRMessage 'Main', 'REXX function library 'strip(translate(word(sourceline(sigl -1),4),' ',",'))'.DLL is missing!','EVFSGUI fatal error','E'; "

Screenshot: http://asavage.dyndns.org/ftp/hosting/eCS/Samba/Samba_03b.png

It has not been seen since.

Steven Levine opines: "This looks like two problems. One is an intermittently unloadable DLL and another is a failure of the error reporting code.

Attachments (1)

Samba_03b.png (6.2 KB) - added by asavage 6 years ago.

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by asavage

comment:1 Changed 6 years ago by stevenhl

  • Cc steve53@… added

comment:2 Changed 6 years ago by asavage

Similar issues in this scenario also occur on other OS/2 boxes I have, though on those (WSA on one, W4 FP17 on another) the box is locked up completely after <Enter> on marked text in a closed VIO window.

On the eCS 2.1 box:

If the "Completed: xxxxxxx" session is closed (via the window control "X"), other VIO sessions begin accepting keyboard input again.

However, in testing, I was unable after that point to successfully open Firefox 10.0.12ESR. The icon for FF would stay hatched, but Top showed it consuming no CPU cycles, and a frame was never drawn; I rebooted.

comment:3 Changed 6 years ago by herwigb

Please provide EVFSGUI.ERR!

comment:4 Changed 6 years ago by herwigb

  • Status changed from new to assigned

I can reprocduce your problem.

I tracked it down to a VX-REXX problem, as it works within the VX-IDE, but not in the compiled binary. Currently I found no way to overcome this.

This is under investigation!

comment:5 Changed 6 years ago by herwigb

  • Status changed from assigned to accepted

comment:6 Changed 6 years ago by diver

  • Milestone set to Samba Client GUI (EVFSGUI) 2.1

comment:7 Changed 5 years ago by herwigb

  • Resolution set to not fixable
  • Status changed from accepted to closed

This is a VX-REXX bug.

comment:8 Changed 5 years ago by ataylor

If I interpret the report correctly, the error message looks as if it's caused by trying to use Sourceline(sigl) in the error handler.

Sourceline() does not appear to work in compiled VX-REXX binaries. (It does work from the Designer, which is misleading.)

comment:9 Changed 5 years ago by herwigb

  • Resolution not fixable deleted
  • Status changed from closed to reopened

Rewrote the errorhandler. It just does not report which DLL is missing in the compiled binary. No crash anymore however.

The fix will be in EVFSGUI 2.5 RC7 or better.

comment:10 Changed 5 years ago by herwigb

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 4 years ago by diver

  • Milestone changed from Samba Client GUI (EVFSGUI) 2.1 to Samba Client GUI (EVFSGUI) 2.x

Milestone renamed

Note: See TracTickets for help on using tickets.