Opened 8 years ago

Closed 7 years ago

#187 closed defect (fixed)

smbd.exe blocks after 25.000 files

Reported by: Leo123 Owned by: diver
Priority: Feedback Pending Milestone: Samba Server for eCS (OS/2) 1.2.0
Component: Samba Server Version: Server 3.3.x
Keywords: Cc:

Description (last modified by herwigb)

I am trying to use Samba for the backup of my system. I use a scsi tapedrive in a client for that. The samba server 3.3.16 get into problems after about 25.000 files. I get:

From log.smbd.leo.10.0.0.153:

Killed by SIGFPE
pid=0x00bb ppid=0x008a tid=0x0001 slot=0x00c0 pri=0x0400 mc=0x0001
D:\PROGRAMS\SAMBA\SMBD.EXE
LIBC064X 0:00035096
cs:eip=005b:11125096      ss:esp=0053:0061f240      ebp=0061f278
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010293
eax=00000000 ebx=00000000 ecx=0061f260 edx=00000018 edi=113d8a10 esi=00000000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
-toezichthouders/slides/P3270104.JPG read=Yes write=No (numopen=1)
[2012/02/01 14:52:03,  1] lib/util_tdb.c:tdb_wrap_log(886)
  tdb(D:\MPTN\ETC\samba\lock/locking.tdb): tdb_lock failed on list -1 ltype=3 (Invalid argument)
[2012/02/01 14:52:03,  0] locking/locking.c:share_mode_lock_destructor(747)
  store returned NT_STATUS_UNSUCCESSFUL
[2012/02/01 14:52:03,  0] lib/util.c:smb_panic(1686)
  PANIC (pid 391): could not store share mode entry
[2012/02/01 14:52:03,  0] lib/util.c:log_stack_trace(1840)
  unable to produce a stack trace on this platform
[2012/02/01 14:52:03,  0] lib/fault.c:dump_core(235)
  dumping core in D:\MPTN\ETC/samba/log/cores/smbd

Killed by SIGABRT
pid=0x0187 ppid=0x008a tid=0x0001 slot=0x00b4 pri=0x0400 mc=0x0001
D:\PROGRAMS\SAMBA\SMBD.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
[2012/02/01 14:52:06,  2] auth/auth.c:check_ntlm_password(308)

and so on.

I canot find anyting about this in the samba info on www.samba.org so it may be abug in the eCS version of smbd.exe

Attachments (5)

log.zip (127.3 KB) - added by Leo123 7 years ago.
log-dir.txt (5.9 KB) - added by Leo123 7 years ago.
Samba.jpg (38.0 KB) - added by Leo123 7 years ago.
log_nmbd.zip (190.3 KB) - added by Leo123 7 years ago.
As requested the logfiles
smb.conf (3.4 KB) - added by Leo123 7 years ago.
As requested my smb.conf file

Download all attachments as: .zip

Change History (26)

comment:2 Changed 8 years ago by herwigb

  • Description modified (diff)

comment:3 in reply to: ↑ 1 Changed 8 years ago by Leo123

Replying to herwigb:

Please retry with ftp://ftp.netlabs.org/pub/samba/server/test/samba-1-1-2-678-3_3_1_6-libc064-test.zip

Herwig, till now this seems better. However, when I start the server seven PID's are used: three for smbd.exe, two for nmbd.exe and two for winbindd.exe. A few seconds later the last two are not running anymore while smbd.exe runs on/with(?) one PID. After restarting the samba daemons all keeps running in/with six PID's

comment:4 Changed 8 years ago by herwigb

Please delete and do not run winbindd.exe (although it is surely unrelated to your problem), as it will not work (at least it did not work when it was tested last time).

After a fresh start you should see 2 smbd.exe PIDs and 2 nmbd.exe PIDs before anybody connects.

Later on you should see the 2 original nmbd and the 2 original smbd plus another smbd for every connection to the server.

If this does not apply to you, we needs all log.nmbd.* and log.smbd.* created during startup at loglevel 10.

Here is another testbuild you might want to try: ftp://ftp.netlabs.org/pub/samba/server/test/samba-1-1-2-687-3_3_16-libc064.zip

comment:5 Changed 8 years ago by diver

do you still see that behavior with the latest samba build?

might be related to #189

Last edited 8 years ago by diver (previous) (diff)

comment:6 Changed 8 years ago by diver

  • Priority changed from critical to Feedback Pending

if you still see a SIGABRT with all the latest samba, please provide a level 10 log. as a level 1 log just gives almost no info about whats going on

comment:7 Changed 7 years ago by diver

additionally use the following smb.conf entry
log file = x:\samba/log\smbd.%d
or similar. at laest make sure the %d is there, so we get a log for every pid. then only attach the log which has the crash inside.

comment:8 Changed 7 years ago by Leo123

I added the %d.

At times nmbd.exe still stops running: status: not running. No problem with smbd.exe.

Which log do you require?

The log when smbd.exe is running while nmbd.exe is not running?

Or after a 'restart daemons'?

Or after a 'stop daemons'?

Last edited 7 years ago by Leo123 (previous) (diff)

comment:9 Changed 7 years ago by diver

if you still get the SIGFPE/SIGABRT i need a log with the %d switch and log level 10. but only from the crashed process. so you have to see which one it is.

Changed 7 years ago by Leo123

comment:10 Changed 7 years ago by Leo123

Here are the logs after nmbd.exe stopped running.

comment:11 Changed 7 years ago by diver

i need to insert some debug to http://svn.netlabs.org/samba/browser/branches/samba-3.3.x/source/lib/util_sock.c function read_udp_v4_socket() as i suspect something it crashes there.

comment:12 Changed 7 years ago by herwigb

Try this build please and provide loglevel 10 logs as before. Nothing fixed, just more debugs. ftp://ftp.netlabs.org/pub/samba/server/test/test-ticket-187.zip

comment:13 Changed 7 years ago by Leo123

I am trying that build with loglevel 10.
Result: 83 files total 5.121 MB see log-dir.txt
Do you whish me to send 5GB? How?

Changed 7 years ago by Leo123

Changed 7 years ago by Leo123

comment:14 Changed 7 years ago by Leo123

See also Samba.jpg

comment:15 Changed 7 years ago by diver

as only the nmbd crashes please zip the nmbd.log and attach it here.

Changed 7 years ago by Leo123

As requested the logfiles

comment:16 Changed 7 years ago by diver

  • Milestone set to Samba Server for eCS (OS/2) 1.2.0

could you also post your smb.conf file? this issue is very strange, as i can't reproduce it.

Changed 7 years ago by Leo123

As requested my smb.conf file

comment:17 Changed 7 years ago by diver

is smbd still blocking/crashing after 25000 files?
is nmbd still crashing or just not working anymore?
i must say i somehow lost track on that issue.

comment:18 Changed 7 years ago by Leo123

nmbd.exe still stops running: 'not running' in the Samba Status Monitor.

During the backup of july 28:

  1. after around 45,000 files; 3.5 GB
  1. after around 65,000 files; 4.8 GB

The logfiles have been overwritten by a later incremental (small) backup.

I seem to be using nmbd version 3.3.16-eCS 1.1.2-703

comment:19 Changed 7 years ago by diver

so only nmbd stops running now and smbd runs w/o problems?

comment:20 Changed 7 years ago by Leo123

It seems so, yes.
See Samba.jpg which I uploaded june 30, 2012.
I do not know what causes nmbd.exe to stop.
Perhaps there is a possibility that smbd.exe has an influence on the stopping of nmbd.exe? smbd.exe runs but I do not know if it is w/o problems, as you ask.
smbd.exe: 5.378.052 bytes, date 20-06-02012

comment:21 Changed 7 years ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

as it seems like the smbd problem is fixed here i close this ticket. as ticket:206 also deals with nmbd problems.

Note: See TracTickets for help on using tickets.