Opened 10 years ago

Closed 10 years ago

#145 closed defect (fixed)

Problems with SAMBA server 1.1.0

Reported by: David McKenna Owned by: Herwig Bauernfeind
Priority: major Milestone: Samba Server for eCS (OS/2) 1.1.0
Component: Samba Server GUI Tools Version: Server 3.3.x
Keywords: Cc:

Description

Thanks for all you have done with SAMBA! Today was a rainy day, so I stayed home and spent some time trying the recent versions of SAMBA server you have released.

My setup: SAMBA Domain Server running eCS 1.2MR, Client running eCS 2.0GA, Client running WinXP SP3, Client (Laptop) dual boot eCS 2.0 and WinXP.

I have SAMBA 1.0.4 installed and configured for my setup. Everything works. I installed 1.0.5 (from the WPI) and I was able to use everything as before. All clients logon (I use IBM LAN Logon on eCS), see the shares and I can use the utilities as well as SWAT.

I made a copy of smb.conf, then installed 1.1.0 from the WPI. After installation, I added all of the same users as before (there are 6, including 2 machines). I tried to start SWAT, but I got an 'Internal Server Error' (using Apache 2.2.16). I switched to SSCC and added the Domain name, then restarted. The Windows clients could logon and see shares (after joining the domain), but not the eCS clients - the logon would fail and the dialog for name, password and domain would reappear. I then copied the old smb.conf (which worked before with 1.0.5) over the new one and restarted SAMBA, but still only the Windows clients could logon.

I then un-installed 1.1.0 (using WarpIn?) and deleted all remnants of files and directories of SAMBA, then rebooted. Next I installed 1.1.0 fresh, but after install still could not use SWAT (Internal Server Error), so again used SSCC to change domain name, then added users as before. Still, only the Windows clients could logon. Adding the saved smb.conf did not help here either.

I decided to give up and un-installed 1.1.0, then re-installed 1.0.5, then added users and domain. Once again everything worked fine.

My knowledge of the internals of SAMBA is sketchy at best, but it seems smb.conf only contains those entries that are not 'default'. Perhaps 'defaults' have changed in version 1.1.0 so I need to add something to get the eCS clients to logon? I will continue to scrutinize defaults for 1.0.5 and 1.1.0 - maybe something will jump out...

Still a mystery why SWAT won't work though...

Change History (10)

comment:1 Changed 10 years ago by Herwig Bauernfeind

Version: 3.0.343.3.x

SWAT does not work in 1.1.0 because I accidentally packaged SWAT from 3.0.37 instead of SWAT from 3.3.13. Sorry. This will be fixed in the next revision.

Regarding the login from eCS Clients using IBM-LAN-Requester: Please note that the Samba people changed several default values for Samba between 3.0 and 3.3. I know these changes affect IBM-LAN Requester compatibility.

So, in order to use Samba 3.3 and IBM-LAN-Requester together, you MUST change several defaults in smb.conf to the values 3.0 used. In addition it is necessary to change IBMLAN.INI (see FAQ for that!) for Samba 3.2 or better.

comment:2 Changed 10 years ago by Herwig Bauernfeind

Owner: changed from nobody to Herwig Bauernfeind
Status: newassigned

comment:3 Changed 10 years ago by David McKenna

I tried the suggested settings in the FAQ, but I still can not logon to SAMBA 1.1.0 using LAN Requestor clients. The error I get is 'The logon attempt was unsuccessful.' I'll keep looking...

comment:4 Changed 10 years ago by Herwig Bauernfeind

The FAQ only deals with speed issues between Samba 3.2 or better and IBM-LAN-Requester and their resolution by modifying IBMLAN.INI. It does not deal with login issues.

Please, read here, AFAIK this should solve your problems.

comment:5 Changed 10 years ago by David McKenna

Thanks! That page had all the info I needed. I had figured out the 'lanman auth' bit, but not the password damage. You should definitely add that page to your FAQ, or maybe a warning to add 'lanman auth = Yes' to smb.conf BEFORE starting SAMBA the first time (if upgrading). Even better would be if the WPI did it for you.

While trying to figure this out, I discovered a nasty bug in SSCC (in 1.1.0) - if set to display expert mode and you make a change, then save, then close SSCC, the resulting smb.conf is empty except for 3 lines of header. Naturally SAMBA doesn't start with this.

Also, I notice that the SECURITY setting is set to 'user' when you start SSCC in simple or expert mode regardless of the real value of SECURITY. This happens on both 1.0.5 and 1.1.0.

I look forward to an updated SWAT.

Thanks again!

comment:6 Changed 10 years ago by Herwig Bauernfeind

Component: UnknownSamba Server GUI Tools

comment:7 Changed 10 years ago by Herwig Bauernfeind

FAQ updated, will investigate SSCC. Thanks for providing feedback.

comment:8 Changed 10 years ago by Herwig Bauernfeind

I can reproduce the problem with SSCC trashing smb.conf. Don't know yet what exactly is going on. Created a new Ticket #146 for that, as this unrelated to the rest...

comment:9 Changed 10 years ago by Herwig Bauernfeind

ok, SWAT works normally with our Samba 3.3 when packaged and installed properly. THis will be fixed in the next drop.

comment:10 Changed 10 years ago by Herwig Bauernfeind

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.