Opened 9 years ago

Closed 9 years ago

#134 closed defect (invalid)

smbclient.exe cannot handle --command parameters properly

Reported by: herwigb Owned by: nobody
Priority: major Milestone: Samba Server for eCS (OS/2) 1.1.0
Component: Samba Client Command line utilities Version: 3.3.6
Keywords: Cc:

Description

When running smbclient.exe with --command all parameters for a given command are ignored.

For example:

smbclient \\srv\data --user=xxxx%xxxx --command dir

works, where

smbclient \\srv\data --user=xxxx%xxxx --command dir *.exe

does not, with the respect that *.exe is ignored. The same applies at least to several other commands (tested with put and get).

Change History (2)

comment:1 Changed 9 years ago by herwigb

smbclient \\srv\data --user=xxxx%xxxx --command "dir *.exe"

seems to do the trick. Note the quotation marks!

comment:2 Changed 9 years ago by herwigb

  • Resolution set to invalid
  • Status changed from new to closed

THis seems to be the expected behaviour.

Note: See TracTickets for help on using tickets.