Custom Query (326 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (40 - 42 of 326)

Ticket Resolution Summary Owner Reporter
#347 fixed Dummy Warpin entries in *wrong* database - wpi4rpm error? losepete
Description

Having used ANPM to update some files I had error messages about not being able to identify the correct DATBAS_?.INI to use and a new file, DATBAS_D.INI, was created as a result.

I have 3 ArcaOS installations on the same disk, H: L: M:

Warpin can handle this without problems as it uses DATBAS_H.INI when booted from H:, DATBAS_L.INI when booted from L: and DATBAS_M.INI when booted from M:

Here is an ANPM log snippet showing the problem:-


Executing: @python J:\PROGRAMS\UTILS\ANPM\scripts\yum_update_dep.py bc coreutils coreutils-common cube dash fontconfig glib2 gmp klusrmgr less libglib-2_0-0 libgmodule-2_0-0 libgobject-2_0-0 libgthread-2_0-0 libusbcalls rxcrypt sed sqlite tcl unzip zip Return code: 0


Executing: @python J:\PROGRAMS\UTILS\ANPM\scripts\yum_update.py bc coreutils coreutils-common cube dash fontconfig glib2 gmp klusrmgr less libglib-2_0-0 libgmodule-2_0-0 libgobject-2_0-0 libgthread-2_0-0 libusbcalls rxcrypt sed sqlite tcl unzip zip Running Transaction Check Warning: RPMDB altered outside of yum. Found 1 pre-existing rpmdb problem(s), 'yum check' output follows: os2-base-0.0.1-2.oc00.i686 is a duplicate with os2-base-0.0.0-19.oc00.i686 Non-fatal POSTIN scriptlet failure in rpm package klusrmgr-1.4.0-1.oc00.i686 ERROR: wpi4rpm: Warning: 4 WarpIN databases found. Using J:\PROGRAMS\UTILS\WARPIN\DATBAS_D.INI

ERROR: wpi4rpm: Warning: 4 WarpIN databases found. Using J:\PROGRAMS\UTILS\WARPIN\DATBAS_D.INI

ERROR: wpi4rpm: Warning: 4 WarpIN databases found. Using J:\PROGRAMS\UTILS\WARPIN\DATBAS_D.INI

ERROR: wpi4rpm: Warning: 4 WarpIN databases found. Using J:\PROGRAMS\UTILS\WARPIN\DATBAS_D.INI

Surely wpi4rpm should check what boot drive letter is in use and select the DATBAS_?.INI file based on the boot drive letter to avoid the above problem.

Related is that the entries in DATBAS_D.INI cannot be read by Warpin, some sort of header problem, so the DATBAS_D.INI file is of no use to anyone - especially Warpin.

#314 fixed Duplicate WarpIn database error David McKenna
Description

Just tried to update klusrmgr using ANPM and it ended with an error saying there was multiple WarpIn? databases. I only have one DATBAS_C.INI file on my computer, so opened up Warpin.exe and saw that there was an entry for every version of klusrmgr ever installed on this machine. Deleted all the entries and closed Warpin, then reinstalled klusrmgr using ANPM, this time it completed with no problem and created its objects. (Also noticed extra entries for bwwping, so trimmed those out too). Is it necessary to have a separate entry in Warpin for every version of klusrmgr installed?

#282 fixed Error from Auto-update-debuginfo Tellie
Description

I have installed yum-utils and activate the Auto-update-debuginfo But when running yum gives errors like:


Executing: @python C:\USR\SBIN\yum-complete-transaction -y Loaded plugins: auto-update-debuginfo, fastestmirror Traceback (most recent call last):

File "C:\USR\SBIN\yum-complete-transaction", line 258, in <module>

util = YumCompleteTransaction?()

File "C:\USR\SBIN\yum-complete-transaction", line 118, in init

self.main()

File "C:\USR\SBIN\yum-complete-transaction", line 156, in main

self.doUtilYumSetup()

File "/@unixroot/usr/share/yum-cli/utils.py", line 313, in doUtilYumSetup

self._getTs()

File "C:/USR/lib/python2.7/site-packages/yum/depsolve.py", line 101, in _getTs

self._getTsInfo(remove_only)

File "C:/USR/lib/python2.7/site-packages/yum/depsolve.py", line 112, in _getTsInfo

pkgSack = self.pkgSack

File "C:/USR/lib/python2.7/site-packages/yum/__init__.py", line 895, in <lambda>

pkgSack = property(fget=lambda self: self._getSacks(),

File "C:/USR/lib/python2.7/site-packages/yum/__init__.py", line 676, in _getSacks

self.repos.populateSack(which=repos)

File "C:/USR/lib/python2.7/site-packages/yum/repos.py", line 265, in populateSack

self.doSetup()

File "C:/USR/lib/python2.7/site-packages/yum/repos.py", line 72, in doSetup

self.ayum.plugins.run('prereposetup')

File "C:/USR/lib/python2.7/site-packages/yum/plugins.py", line 184, in run

func(conduitcls(self, self.base, conf, kwargs))

File "/@unixroot/usr/lib/yum-plugins/auto-update-debuginfo.py", line 121, in prereposetup_hook

enable_debuginfo_repos(yb, conduit)

File "/@unixroot/usr/lib/yum-plugins/auto-update-debuginfo.py", line 41, in enable_debuginfo_repos

if opts is not None and hasattr(opts.repos) :

TypeError?: hasattr expected 2 arguments, got 1 Return code: 0

Silvan says the fix is @ https://github.com/rpm-software-management/yum-utils/commit/efb3c7b3fb96523bb5997c163bf4e33ab897f1b8

I tried it and it works now..

Note: See TracQuery for help on using queries.