1 | Name: perl-Devel-StackTrace
|
---|
2 | Summary: Perl module implementing stack trace and stack trace frame objects
|
---|
3 | Version: 2.03
|
---|
4 | Epoch: 1
|
---|
5 | Release: 1%{?dist}
|
---|
6 | License: Artistic 2.0
|
---|
7 | Group: Development/Libraries
|
---|
8 | Vendor: bww bitwise works GmbH
|
---|
9 | URL: http://search.cpan.org/dist/Devel-StackTrace/
|
---|
10 | Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Devel-StackTrace-%{version}.tar.gz
|
---|
11 | BuildArch: noarch
|
---|
12 |
|
---|
13 | # --with release_tests ... also check "RELEASE_TESTS".
|
---|
14 | # Disabled by default
|
---|
15 | #%bcond_with release_tests
|
---|
16 |
|
---|
17 | # --with author_tests ... also check "AUTHOR_TESTS".
|
---|
18 | # Disabled by default
|
---|
19 | #%bcond_with author_tests
|
---|
20 |
|
---|
21 | BuildRequires: perl-generators
|
---|
22 | BuildRequires: %{__perl}
|
---|
23 | BuildRequires: %{__make}
|
---|
24 |
|
---|
25 | BuildRequires: perl(base)
|
---|
26 | BuildRequires: perl(bytes)
|
---|
27 | BuildRequires: perl(ExtUtils::MakeMaker)
|
---|
28 | BuildRequires: perl(File::Spec)
|
---|
29 | BuildRequires: perl(IO::Handle)
|
---|
30 | BuildRequires: perl(IPC::Open3)
|
---|
31 | BuildRequires: perl(overload)
|
---|
32 | BuildRequires: perl(Test::More) >= 0.88
|
---|
33 | BuildRequires: perl(Scalar::Util)
|
---|
34 | BuildRequires: perl(strict)
|
---|
35 | BuildRequires: perl(warnings)
|
---|
36 | Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
---|
37 |
|
---|
38 | #%if %{with release_tests}
|
---|
39 | # for improved tests
|
---|
40 | #BuildRequires: perl(Exception::Class::Base)
|
---|
41 | #BuildRequires: perl(Pod::Coverage::TrustPod)
|
---|
42 | #BuildRequires: perl(Test::CPAN::Changes)
|
---|
43 | #BuildRequires: perl(Test::EOL)
|
---|
44 | #BuildRequires: perl(Test::NoTabs)
|
---|
45 | #BuildRequires: perl(Test::Pod) > 1.41
|
---|
46 | #BuildRequires: perl(Test::Pod::Coverage) >= 1.08
|
---|
47 | #BuildRequires: perl(Test::Pod::LinkCheck)
|
---|
48 | #BuildRequires: perl(Test::Pod::No404s)
|
---|
49 | #BuildRequires: perl(Test::Portability::Files)
|
---|
50 | #BuildRequires: perl(Test::Synopsis)
|
---|
51 | #BuildRequires: perl(LWP::Protocol::https)
|
---|
52 | #%endif
|
---|
53 |
|
---|
54 | #%if %{with author_tests}
|
---|
55 | #BuildRequires: perl(Pod::Coverage::TrustPod)
|
---|
56 | #BuildRequires: perl(Test::CPAN::Changes)
|
---|
57 | #BuildRequires: perl(Test::EOL)
|
---|
58 | #BuildRequires: perl(Test::NoTabs)
|
---|
59 | #BuildRequires: perl(Test::Pod) > 1.41
|
---|
60 | #BuildRequires: perl(Test::Pod::Coverage) >= 1.08
|
---|
61 | #BuildRequires: perl(Test::Spelling) >= 0.12
|
---|
62 | #BuildRequires: perl(Test::Synopsis)
|
---|
63 | # N/A in Fedora: BuildRequires: perl(Code::TidyAll::Plugin::SortLines::Naturally) >= 0.000003
|
---|
64 | #BuildRequires: perl(Code::TidyAll::Plugin::Test::Vars) >= 0.02
|
---|
65 | #BuildRequires: perl(Parallel::ForkManager) >= 1.19
|
---|
66 | #BuildRequires: perl(Perl::Critic) >= 1.126
|
---|
67 | #BuildRequires: perl(Perl::Tidy) >= 20160302
|
---|
68 | #BuildRequires: perl(Test::CPAN::Meta::JSON) >= 0.16
|
---|
69 | #BuildRequires: perl(Test::Code::TidyAll) >= 0.50
|
---|
70 | #BuildRequires: perl(Test::Mojibake)
|
---|
71 | #BuildRequires: perl(Test::Portability::Files)
|
---|
72 | #BuildRequires: perl(Test::Vars) >= 0.009
|
---|
73 | #BuildRequires: perl(Test::Version) >= 2.05
|
---|
74 | #%endif
|
---|
75 |
|
---|
76 | %description
|
---|
77 | The Devel::StackTrace module contains two classes, Devel::StackTrace
|
---|
78 | and Devel::StackTraceFrame. The goal of this object is to encapsulate
|
---|
79 | the information that can found through using the caller() function, as
|
---|
80 | well as providing a simple interface to this data.
|
---|
81 |
|
---|
82 | The Devel::StackTrace object contains a set of Devel::StackTraceFrame
|
---|
83 | objects, one for each level of the stack. The frames contain all the
|
---|
84 | data available from caller() as of Perl 5.6.0.
|
---|
85 |
|
---|
86 | %prep
|
---|
87 | %setup -q -n Devel-StackTrace-%{version}
|
---|
88 |
|
---|
89 | %build
|
---|
90 | %{__perl} Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
|
---|
91 | make %{?_smp_mflags}
|
---|
92 | make manifypods
|
---|
93 |
|
---|
94 | %install
|
---|
95 | %{__make} pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
|
---|
96 | find %{buildroot} -type f -name .packlist -delete
|
---|
97 | %{_fixperms} $RPM_BUILD_ROOT/*
|
---|
98 |
|
---|
99 | %check
|
---|
100 | #%{__make} test %{?with_release_tests:RELEASE_TESTING=1} %{?with_author_tests:AUTHOR_TESTING=1}
|
---|
101 |
|
---|
102 | %files
|
---|
103 | %doc Changes
|
---|
104 | %license LICENSE
|
---|
105 | %{perl_vendorlib}/Devel
|
---|
106 | %{_mandir}/man3/*
|
---|
107 |
|
---|
108 | %changelog
|
---|
109 | * Wed Mar 14 2018 Elbert Pol <elbert.pol@gmail.com> - 2.03-1
|
---|
110 | - initial rpm for OS2
|
---|