source: spec/trunk/SPECS/libtool.spec@ 444

Last change on this file since 444 was 444, checked in by dmik, 11 years ago

spec: libtool Release version 2.4.2-2.

File size: 5.2 KB
Line 
1# Note: this .spec is borrowed from libtool-2.4.2-21.fc20.src.rpm
2
3%global gcc_version 4.7.3
4
5Summary: The GNU Portable Library Tool
6Name: libtool
7Version: 2.4.2
8Release: 2%{?dist}
9License: GPLv2+ and LGPLv2+ and GFDL
10URL: http://www.gnu.org/software/libtool/
11Group: Development/Tools
12
13#Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
14
15%define svn_url http://svn.netlabs.org/repos/ports/libtool/trunk
16%define svn_rev 842
17
18Source: %{name}-%{version}-r%{svn_rev}.zip
19
20BuildRequires: gcc make subversion
21
22#Requires(post): /sbin/install-info
23#Requires(preun): /sbin/install-info
24
25BuildRequires: autoconf, automake
26#BuildRequires: texinfo
27Requires: autoconf, automake, sed, tar
28
29# make sure we can configure all supported langs
30#BuildRequires: libstdc++-devel, gcc-gfortran
31
32# /usr/bin/libtool includes paths within gcc's versioned directories
33# Libtool must be rebuilt whenever a new upstream gcc is built
34Requires: gcc >= %{gcc_version}
35Requires: gcc <= %{gcc_version}.999
36
37%description
38GNU Libtool is a set of shell scripts which automatically configure UNIX and
39UNIX-like systems to generically build shared libraries. Libtool provides a
40consistent, portable interface which simplifies the process of using shared
41libraries.
42
43If you are developing programs which will use shared libraries, but do not use
44the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
45should install the libtool package.
46
47The libtool package also includes all files needed to integrate the GNU
48Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
49(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
50and GNU Automake).
51
52%package ltdl
53Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
54Group: System Environment/Libraries
55Provides: %{name}-libs = %{version}-%{release}
56License: LGPLv2+
57
58%description ltdl
59The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
60library that provides a consistent, portable interface which simplifies the
61process of using dynamic modules.
62
63These runtime libraries are needed by programs that link directly to the
64system-installed ltdl libraries; they are not needed by software built using
65the rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
66
67%package ltdl-devel
68Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
69Group: Development/Libraries
70Requires: %{name}-ltdl = %{version}-%{release}
71License: LGPLv2+
72
73%description ltdl-devel
74Static libraries and header files for development with ltdl.
75
76%prep
77%if %(sh -c 'if test -f "%{_sourcedir}/%{name}-%{version}-r%{svn_rev}.zip" ; then echo 1 ; else echo 0 ; fi')
78%setup -q
79%else
80%setup -n "%{name}-%{version}" -Tc
81svn export -r %{svn_rev} %{svn_url} . --force
82rm -f "%{_sourcedir}/%{name}-%{version}-r%{svn_rev}.zip"
83(cd .. && zip -SrX9 "%{_sourcedir}/%{name}-%{version}-r%{svn_rev}.zip" "%{name}-%{version}")
84%endif
85
86# make sure configure is updated to properly support OS/2
87bootstrap
88
89%build
90
91# we don't have makeinfo/help2man yet; fake it (this will keep the old docs)
92export MAKEINFO=:
93export HELP2MAN=:
94
95%configure --prefix=%{_prefix} \
96 --exec-prefix=%{_prefix} \
97 --bindir=%{_bindir} \
98 --sbindir=%{_sbindir} \
99 --sysconfdir=%{_sysconfdir} \
100 --datadir=%{_datadir} \
101 --includedir=%{_includedir} \
102 --libdir=%{_libdir} \
103 --libexecdir=%{_libexecdir} \
104 --localstatedir=%{_localstatedir} \
105 --mandir=%{_mandir} \
106 --infodir=%{_infodir}
107
108## build not smp safe:
109make # %%{?_smp_mflags}
110
111#for i in ChangeLog.1997 ChangeLog.1998 ChangeLog.1999 ChangeLog.2002; do
112# iconv -f ISO_8859-15 -t UTF8 $i > $i.tmp
113# mv -f $i.tmp $i
114#done
115
116#%check
117#make check VERBOSE=yes
118
119%install
120rm -rf ${buildroot}
121make install DESTDIR=%{buildroot}
122
123# info's TOP dir (by default owned by info)
124rm -f %{buildroot}%{_infodir}/dir
125# *.la *.a files generated by libtool shouldn't be distributed (and the
126# `./configure --disable-static' breaks testsuite)
127rm -f %{buildroot}%{_libdir}/libltdl.la
128rm -f %{buildroot}%{_libdir}/ltdl.a
129
130#%post
131#/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
132
133%preun
134if [ "$1" = 0 ]; then
135 /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
136fi
137
138%files
139%defattr(-,root,root)
140%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog*
141#%{_infodir}/libtool.info*.gz
142%{_mandir}/man1/libtool.1*
143%{_mandir}/man1/libtoolize.1*
144%{_bindir}/libtool
145%{_bindir}/libtoolize
146%{_datadir}/aclocal/*.m4
147%exclude %{_datadir}/libtool/libltdl
148%{_datadir}/libtool
149
150%files ltdl
151%defattr(-,root,root)
152%doc libltdl/COPYING.LIB
153%{_libdir}/ltdl*.dll
154
155%files ltdl-devel
156%defattr(-,root,root)
157%doc libltdl/README
158%{_datadir}/libtool/libltdl
159%{_includedir}/ltdl.h
160%{_includedir}/libltdl
161# Import libraries must be in -devel subpackage
162%{_libdir}/ltdl*_dll.a
163
164%changelog
165* Mon Sep 1 2014 Dmitriy Kuminov <coding@dmik.org> 2.4.2-2
166- Fix PATH_SEPARATOR detection in libtoolize.
167
168* Sun Aug 31 2014 Dmitriy Kuminov <coding@dmik.org> 2.4.2-1
169- Initial package for version 2.4.2.
Note: See TracBrowser for help on using the repository browser.