Opened 7 years ago

Closed 6 years ago

#93 closed defect (fixed)

In Java filemanagement options don't work

Reported by: Joop Owned by:
Priority: minor Milestone: 0.8.9
Component: odin Version: 0.8.7
Severity: medium Keywords:
Cc:

Description

If I install Odin 0.8.7 and let it run with Java 1.6GA (first version, later version don't show menu items, see ticket on wiki Java) then I can't in the filemanager choose for an other presentation, can't sort the files on name or date (as an example). As soon as I install Odin 0.7.1 then I have the options back and can do what I want. I did test it with Odin 0.8.7 and Java 1.6GA (first release) and Total Validator (Java program) and same but now with Odin 0.7.1.

Change History (7)

comment:1 Changed 7 years ago by Joop

There are more programs with same behavior like Jave. Because the directory structure is not loaded you can't load or save files. As soon as you go back to the combination of JAVA 1.60GA (first release) and ODIN 0.7.1 you get full control over directories and files.

comment:2 Changed 7 years ago by dmik

JFYI. This works in Odin 0.7.1 indeed. I will check the differences.

Note that the ImageJ program uses AWT which is basically a mapping of native Win32 GUI APIs to Java. It is known that these APIs are not complete in Odin -- because we don't use them much (the only important exception is AWT but AWT programs are quite rare and old -- so this has always been a low priority.

But given it's so easy to reproduce, I will try to fix it.

comment:3 Changed 6 years ago by dmik

  • Milestone changed from next to 0.8.9

comment:4 Changed 6 years ago by dmik

JFYI, all Odins starting from version 0.8.1 contain this bug and only Odin 0.7.1 works. This actually means that it's a regression of the VAC->GCC switch somehow.

comment:5 Changed 6 years ago by dmik

I have checked the code but found nothing so far: the directory items for the combobox are properly enumerated and added to it. It's unclear why they are not seen.

Will now check why OK/Cancel buttons do nothing.

comment:6 Changed 6 years ago by dmik

Hmm, a really strange thing is that the sample Win32 code from here works with the new Odin very well: http://www.daniweb.com/software-development/cpp/code/217307/a-simple-getopenfilename-example. The very same file open dialog code. The only difference is that in Java this code is called not on Thread 1. Theoretically, this may be an issue...

comment:7 Changed 6 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

It turns out that this is an entirely Java problem. Created http://svn.netlabs.org/java/ticket/203 for that. Closing this one.

Note: See TracTickets for help on using tickets.