Opened 6 years ago

Closed 6 years ago

#89 closed defect (fixed)

MSVCR100.DLL requires InitializeSListHead

Reported by: abwillis Owned by:
Priority: major Milestone: 0.8.6
Component: odin Version: 0.8.5
Severity: medium Keywords:
Cc:

Description

Attempting to run Instantbird (instant messaging client based on Mozillia's xulrunner) I receive: The application has called the non-existing api KERNEL32.DLL->InitializeSListHead (loaded by MSVCR100.DLL)

Attachments (1)

interlocked.c (1.4 KB) - added by abwillis 6 years ago.
Initial interlock code before finding the interlock.asm

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by abwillis

Committed revision r22018 Instantbird still does not run, but it no longer crashes. It starts using high cpu and just runs for as long as I have left it to run. This is the same thing I had seen from older Mozilla applications that did not require msvcr100.dll and thus did not require this update which at least means this code gets past the initial error and is not the cause of the high cpu.

Changed 6 years ago by abwillis

Initial interlock code before finding the interlock.asm

comment:2 Changed 6 years ago by abwillis

I initially did not know about or see the interlock.asm file and had created an interlock.c under ntdll. Attaching primarily in case anyone wants to remove ALP dependency in the future considering I had spent several hours debugging the blasted thing and getting it working before finding the other file :/

comment:3 Changed 6 years ago by dmik

Regarding r22018, good job but please mention where you take the sources from. I guess this was Wine again. This may be needed for further code housekeeping.

comment:4 Changed 6 years ago by abwillis

Yes, this was from Wine.

comment:5 Changed 6 years ago by diver

  • Milestone changed from general enhancement to 0.8.6

comment:6 Changed 6 years ago by abwillis

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.