Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#87 closed defect (fixed)

Can't install OdinApp

Reported by: David McKenna Owned by:
Priority: major Milestone: 0.8.6
Component: odin Version: 0.8.5
Severity: medium Keywords:


Using eCS 2.1 and Odin 0.8.5 installed using YUM. Apps requiring Odin (Java, Flash) seem to work well.

If I try to install the OdinApp? package (after unzipping) using 'pe setup.exe' in an eCS command window, I get the message: 'File not found: D:\var\temp\_ISMP1.DIR\_INS5176._MP.exe'. I click the 'OK' button and the install terminates.

Change History (12)

comment:1 Changed 6 years ago by David McKenna

I should also mention I have odin-exe-tools 0.8.5 installed. The directory d:\var\temp\_ISMP1.DIR does exist, but there is indeed no _INS5176._MP.exe file there - no files in fact. I wonder if the file name with two periods is messing up something....

comment:2 Changed 6 years ago by abwillis

I can confirm this... I do see some files go into the directory though, just not all of them or the exe file in question.

comment:3 Changed 6 years ago by dmik

I can confirm that it doesn't work. However, here I just get an empty "Setup Initialization Error" window with the lone "OK" button. I only get the described behavior (File not found) if I use my current SVN build.

Will investigate it after sorting out Flash issues.

comment:4 Changed 6 years ago by dmik

  • Milestone changed from general enhancement to 0.8.6

comment:5 Changed 6 years ago by dmik

BTW, the problem with my RPM installation is generic: PE/PEC functionality is completely broken in the RPM build. I fixed it in r22015 (a fix for the .spec file has also been committed). For now, as a workaround, you have to copy PE.EXE/PEC.EXE from \usr\bin to \usr\lib.

comment:6 Changed 6 years ago by dmik

I fixed the original issue in r22016. Turned out to be r21942 regression.

However, the installer still does not work. The new error it gives me is "Memory allocation failure while loading _ISDEL.EXE". This must be another regression of r21942 (which is in fact a very important change allowing to load the Win32 EXE at an as low virtual address as possible which is vital for some of the executables). Will look at it later.

comment:7 Changed 6 years ago by abwillis

Installer now works here just fine... the change did have the consequence though of requiring me to now explicitly add .exe to programs I desire to run via pe that are in a different directory e.g. in order to kill hung Lotus Notes Processes I would normally change to c:\notes\data and execute pe ..\nsd -kill but now must execute pe ..\nsd.exe -kill as ..\nsd is not found otherwise. Not much of an issue but something to consider as I have not had to do it in the past.

comment:8 Changed 5 years ago by dmik

Made another attempt to fix this in r22028. Now the old behavior mentioned in comment:7 is restored. The current logic is to only add '.EXE' if there is no (any) extension already specified, regardless of wether there is a path component or not. This in particular means that 'path/name' will be resolved to 'path/name.exe' while 'path/name.myext' will be left intact and loaded as given. This also means that if the real exe has no extension at all, you won't be able to start it with PE/PEC -- but as I've just checked, this matches the behavior of CMD.EXE on both OS/2 and Windows.

So only the low memory condition is an issue for me now. Looking at it.

Last edited 5 years ago by dmik (previous) (diff)

comment:9 Changed 5 years ago by dmik

I fixed the memory allocation error in r22029 but the installer still doesn't work for me. It now simply exits silently, no MSVCRT.DLL installed...

This may somehow be related to the fact that I've been using the RPM layout for the WINDOWS and SYSTEM dirs rather than the traditional one. Checking this.

comment:10 Changed 5 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Shit, my OdinApp? install was broken (os.dat was missing). All works fine after fixing it.

comment:11 Changed 5 years ago by abwillis

My example in comment:7 still has the same behavior where the file is not found if the .exe is not added. If this is the expected behavior then that's OK but that is not what I understood from comment:8. I did test the Odinapp install and it does still work here.

comment:12 Changed 5 years ago by dmik

No, it's not expected. It was an unchecked case. Thanks for testing! Fixed in r22032.

Last edited 5 years ago by dmik (previous) (diff)
Note: See TracTickets for help on using tickets.