Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#84 closed defect (fixed)

Print crash observed under openJDK

Reported by: Lewisr Owned by:
Priority: major Milestone: 0.8.9
Component: odin Version: 0.8.5
Severity: high Keywords: print crash
Cc:

Description

[will cross ref this to openJDK bug list]

Using either openJDK GA2 or GA3 with Odin 0.8.5, printing causes the application to exit. A blank page is ejected from the printer. Printing is to an HP LaserJet?, using the Postscript driver, printing via LPR.

Rolling back to Odin 0.8.4 (and using openJDK GA2), printing works as expected.

Note JVM crash log (full log attached):

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x15429a07, pid=156, tid=10223635
#
# JRE version: 6.0-b24
# Java VM: OpenJDK Client VM (20.0-b12 mixed mode os2-x86 )
# Problematic frame:
# C  [WGSS50+0x9a07]
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Attachments (2)

hs_err_pid156.log (2.3 KB) - added by Lewisr 6 years ago.
Crash log from Moneydance 2011
hs_err_pid124.log (2.3 KB) - added by lewisr 5 years ago.
Current log file of crash (Odin 0.8.8, Java 1.6 GA4)

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Lewisr

Crash log from Moneydance 2011

comment:1 Changed 6 years ago by dmik

What if you use GA3 and Odin 0.8.5?

comment:2 Changed 6 years ago by lewisr

Per my initial description, using either openJDK GA2 or GA3 with Odin 0.8.5 results in this condition, which is what has led me to believe that the problem is with Odin and not with Java.

comment:3 Changed 6 years ago by Lewisr

Confirming that hotfix_ga3_1-20120807.zip for openJDK 6 b25 GA3 has *no* effect on this issue (crash still occurs).

comment:4 Changed 5 years ago by lewisr

This problem is still present through Odin 0.8.8. Presently, I'm stuck at Odin 0.8.4 and the last Java build which ran on that.

Changed 5 years ago by lewisr

Current log file of crash (Odin 0.8.8, Java 1.6 GA4)

comment:5 Changed 5 years ago by dmik

  • Milestone changed from general enhancement to 0.8.9

comment:6 Changed 5 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

The problem has been fixed in r22062 (see commit msg). This is a regression of r21998.

The test from Java ticket 206 now works well.

comment:7 Changed 5 years ago by lewisr

What I can confirm at this time is that installing Odin 0.8.8 and back-leveling gdi32.dll to 0.8.4 works around the issue, so it looks like this was indeed the culprit. Looking forward to a release of 0.8.9.

Thanks so much!

Note: See TracTickets for help on using tickets.