Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#81 closed defect (fixed)

Missing static text in applications window

Reported by: mst Owned by:
Priority: major Milestone: 0.8.5
Component: odin Version: 0.8.x
Severity: low Keywords:
Cc:

Description

This app runs with an older Odin Build 2010-09-06: Dmitry A. Kuminov

Since 0.8.x releases the static text is missing. Only input fields are shown.

http://micrometals.com/downloads/MicroRelease_March2010.exe

Size 1,5MB, no installation needed, start with "pe MicroRelease_March2010.exe"

Attachments (2)

odin084.gif (37.5 KB) - added by mst 6 years ago.
with Odin 0.8.4
odin2010-09-06.gif (48.4 KB) - added by mst 6 years ago.
with odin 2010-09-06

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by abwillis

Potentially related to: http://svn.netlabs.org/java/ticket/164 ?

Changed 6 years ago by mst

with Odin 0.8.4

Changed 6 years ago by mst

with odin 2010-09-06

comment:2 Changed 6 years ago by mst

I think the problem is not related to this ticket, this is not a Java app.

I have attached 2 screenshots now.

odin084.gif shows the app startet with Odin0.8.4 missing text.

odin2010-09-06.gif startet with the old Odin release, all works OK.

comment:3 Changed 6 years ago by dmik

I can confirm that.

comment:4 Changed 6 years ago by dmik

Found the exact version when it broke:

  • 0.6 build 21606 (2011-03-28) -- works.
  • 0.6 build 21632 (2011-05-12) -- broken.

Looking at the change sets.

comment:5 Changed 6 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

I found the culprit: it's r21628. Reverting this change fixes the problem.

Originally, it was made to fix the flipped text when printing from Java (e.g. from jEdit). However, it turns out that the TextOut? implementation in Odin is correct (the test case from this ticket proves this). It means that it was OpenJDK who was using TextOut? (and/or transformation matrices) incorrectly. At least, with the current Odin and r21628 reverted, OpenJDK WSE edition shows flipping problems while OpenJDK GA does not.

Given that GA is still the same source base as WSE (1.6.0 b22), it means that something that fixed flipping comes from us (in the OpenJDK code). I don't want to dig deeper since I don't see any regressions so far (tried pure Win32 apps, Java AWT apps and Java Swing apps). All works.

BTW, with r21628 applied, GA/GA2 would not print correctly from Java apps: the text was not flipped but it was scaled too much for some reason. This means that what we fixed in GA somehow relates to matrix handling.

I reverted r21628 in r21997.

comment:6 Changed 6 years ago by dmik

  • Milestone changed from general enhancement to 0.8.5
Note: See TracTickets for help on using tickets.