Opened 6 years ago

Closed 6 years ago

#78 closed defect (fixed)

Odin 0.8.4

Reported by: Tellie Owned by:
Priority: Feedback Pending Milestone: 0.8.5
Component: odin Version: 0.8.4
Severity: low Keywords:
Cc:

Description (last modified by diver)

I installed 0.8.4-1 with yum

I try to play this game CLUB2000.zip (Same game as in Ticket #54 (closed defect: fixed)

It does nottin, only see this in popup.log

03-19-2012  18:29:01  SYS3175  PID 472a  TID 0004  Slot 00a1
Q:\USR\BIN\PE.EXE
c0000005
1c7cc034
P1=00000001  P2=00000014  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000001  EBX=031d0000  ECX=0004472a  EDX=13e8af20
ESI=1c020394  EDI=00004000  
DS=0053  DSACC=d0f3  DSLIM=5fffffff  
ES=0053  ESACC=d0f3  ESLIM=5fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1c7cc034  CSACC=d0df  CSLIM=5fffffff
SS:ESP=0053:032e0eac  SSACC=d0f3  SSLIM=5fffffff
EBP=032e0ef4  FLG=00010206

KERNEL32.DLL 0001:0000c034

Change History (5)

comment:1 Changed 6 years ago by abwillis

I can confirm the crash in club2000 and also see what looks like the same crash in Lotus Notes 8 which worked with Odin prior to the GCC switchover but I do not recall now if I had it working since then.

03-23-2012  10:24:23  SYS3175  PID 0045  TID 0003  Slot 00b3
E:\ODIN\SYSTEM32\PEC.EXE
c0000005
1ce1c034
P1=00000001  P2=00000014  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000001  EBX=02e00000  ECX=00030045  EDX=1b82af20
ESI=0047c880  EDI=00008000  
DS=0053  DSACC=d0f3  DSLIM=5fffffff  
ES=0053  ESACC=d0f3  ESLIM=5fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1ce1c034  CSACC=d0df  CSLIM=5fffffff
SS:ESP=0053:02f10eac  SSACC=d0f3  SSLIM=5fffffff
EBP=02f10ef4  FLG=00010206

KERNEL32.DLL 0001:0000c034

comment:2 Changed 6 years ago by diver

  • Priority changed from major to Feedback Pending

Andy could you eventually also try odin 0.8.3 and see if it works with that? we think it's probably a 0.8.4 regression.

comment:3 Changed 6 years ago by diver

  • Description modified (diff)
  • Milestone changed from general enhancement to next

comment:4 Changed 6 years ago by diver

  • Milestone changed from next to 0.8.5

comment:5 Changed 6 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Turned out that r21983 didn't fix all the regressions of r21981 (overlooked some occurrences). In r21986 I fixed the root problem (bad coding style of the old code). The crash has gone now.

Note: See TracTickets for help on using tickets.