Opened 3 years ago

Closed 3 years ago

#55 closed defect (fixed)

Odin 0.8.1 vs LIBC064

Reported by: David McKenna Owned by:
Priority: major Milestone: odinized flash
Component: odin Version:
Severity: medium Keywords:
Cc:

Description

Hardware: Intel i3 CPU w/ integrated video, Intel H55 chipset, 2GB DDR3 RAM, USB2, 1 drive- 1 partition , DVD-ROM

Software: eCS 2.1, ACPI, AHCI, RPM/YUM, SeaMonkey? 2.5, LIBC064

I have been using Odin 0.7.1, LIBC064 (both installed with YUM) and Flash in SeaMonkey? 2.5 for awhile and it works with some crashing. I installed Odin 0.8.1 and now Flash does not load in SeaMonkey? - Tools -> Add-ons Manager -> Plugins does not show Flash and websites that need it say I need a plugin. Java apps I have seem to work OK with Odin 0.8.1 (so far).

If I unzip libc063-csd3 over the 064 files in \usr\lib then Flash works in SeaMonkey?. I was even able to use the Flash 11.1 version.

Not sure if this is an Odin or LIBC issue....

Attachments (1)

0062_01.TRP (95.6 KB) - added by abwillis 3 years ago.
TRP from Flash crash with libc064

Download all attachments as: .zip

Change History (11)

comment:1 Changed 3 years ago by abwillis

I built Odin and found that Flash did not work and that Winrar 4.x would crash when the mouse was used (3.9 was fine). I can confirm that putting the original libc063 back in instead of the forwarder does fix these.

comment:2 Changed 3 years ago by abwillis

I find that the winrar problems are actually not fully fixed but Flash does indeed seem to be corrected.

comment:3 Changed 3 years ago by diver

are you both sure there is/was only one libc063.dll available. not that we search some version mismatch

comment:4 Changed 3 years ago by abwillis

Yes, I have the libc063.dll, the original libc063.dll named libc063.dll.old and the new one libc063.dll.new in the d:\ecs\dll directory. which -l libc063.dll shows in d:\ecs\dll. I unlock libc063.dll and copy either the new or the old to libc063.dll and reboot. There is a distinct file size difference to know which is in use. With the original flash works, with the new it crashes the browser.
From the resulting TRP file... will attach the full file.

______________________________________________________________________

 Exception Report - created 2011/12/19 19:57:13
______________________________________________________________________

 SeaMonkey v2.5 - build 20111023211519

 OS2/eCS Version:  2.45
 # of Processors:  2
 Physical Memory:  3070 mb
 Virt Addr Limit:  1536 mb
 Exceptq Version:  7.10 (Mar  1 2011)

______________________________________________________________________

 Exception C0000005 - Access Violation
______________________________________________________________________

 Process:  E:\BROWSERS\WARPZILLA\SEAMONKEY.EXE
 PID:      62 (98)
 TID:      01 (1)
 Priority: 200

 Filename: N/A
 Cause:    Invalid execution address 00000000

______________________________________________________________________

 Registers
______________________________________________________________________

 EAX : 233582E8   EBX  : 233502C0   ECX : 1BC00002   EDX  : 176C0A40
 ESI : 233582E8   EDI  : 0012DC0E
 ESP : 0012DBAC   EBP  : 0012DBE8   EIP : 00000000   EFLG : 00210202
 CS  : 005B       CSLIM: FFFFFFFF   SS  : 0053       SSLIM: FFFFFFFF
 DS  : 0053       ES   : 0053       FS  : 150B       GS   : 0000

 EAX : read/write memory allocated by LIBC064
 EBX : read/write memory allocated by LIBC064
 ECX : read/write memory - owner unknown
 EDX : read/write memory at 0004:00000A40 in NPFLOS2
 ESI : read/write memory allocated by LIBC064
 EDI : read/write memory on this thread's stack


Changed 3 years ago by abwillis

TRP from Flash crash with libc064

comment:5 Changed 3 years ago by David McKenna

I have cleared out all extra libc*.dll's except what is in \usr\lib. I reinstalled libc using YUM, which installed LIBC064. After this, Flash would not load in SeaMonkey? 2.5. I also tried this on my laptop with the same results (using Odin 0.8.1).

After copying the contents of libc063-csd3.zip into \usr\lib and rebooting Flash loads in SeaMonkey? on both my desktop and laptop.

comment:6 Changed 3 years ago by dmik

For some reason, DosDevConfig?(DEVINFO_PRINTER) called from the GCC build of Odin never returns and this causes DosLoadModule?(KERNEL32.DLL) issued by the flash plugin wrapper to never return too. The VAC build of Odin does not show this issue. Really strange. Investigating.

comment:7 Changed 3 years ago by dmik

It was the high-mem issue indeed. DosDevConfig?() is not high-mem safe but it was passed a C++ class instance's field which kLIBC will place in high mem (through the C heap) if the application is compiled with -Zhigh-mem (Mozilla is). Fixed in r21925.

The original Flash10 plugin works here with the GCC Odin now. Andy, can you rebuild SVN and check please?

comment:8 Changed 3 years ago by dmik

Kicking it to send the notification. The previous comment failed to do so because of some SMTP timeout (usual thing in our trac).

comment:9 Changed 3 years ago by abwillis

OK, rebuilt from fresh SVN pull and indeed Flash is now no longer crashing with forwarder libc063.

comment:10 Changed 3 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Ok, good.

Note: See TracTickets for help on using tickets.