#54 closed task (fixed)

(Building) Cannot add required components to Sibyl IDE

Reported by: ataylor Owned by:
Priority: major Milestone:
Component: NewView Version: 2.19
Keywords: Cc:

Description

Trying to set up a NewView build environment with Speedsoft Sibyl (fp3). The instructions in HOWTO.TXT work as far as building the SPU files; unfortunately, attempting to add the components to the Sibyl IDE always produces a cascading series of error popups, generally starting with a message the complib.dll .

Most classes seem to load successfully, except for CustomFontDialog? and TabSet2. Attempting to add either of these using Component -> Install results in an error popup "Could not load component library 'E:\Development\Sibyl\BIN\CompLib?.dll'!", and then a cascading series of error popups saying that NONE of the custom classes can be loaded, sometimes interspersed with some register exception popups.

I can verify that COMPLIB.DLL does exist in E:\Development\Sibyl\BIN:

 1-07-19  8:11p       687,616      0 a---  COMPLIB.DLL

NewView.SPR contains:

[Directories]

LastDir=P:\NEWVIEW_DEV\NEWVIEW
OutDir=P:\newview_dev\build\newview
LibDir=P:\newview_dev\build\components;P:\newview_dev\build\library;P:\newview_dev\build\sibyl\lib
LibSrcDir=P:\newview_dev\library;P:\newview_dev\sibyl\spcc;P:\newview_dev\components;P:\newview_dev\sibyl\rtl
IncSrcDir=
CompInstallDir=P:\NEWVIEW_DEV\build\components

[Directories OS/2]

LastDir=P:\newview_dev\NEWVIEW
OutDir=P:\newview_dev\build
LibDir=P:\newview_dev\build\sibyl\lib;P:\newview_dev\build\components;P:\newview_dev\build\library
LibSrcDir=P:\newview_dev\sibyl\spcc;P:\newview_dev\sibyl\rtl;P:\newview_dev\library;P:\newview_dev\components
IncSrcDir=
CompInstallDir=

Am I missing some critical configuration setting that isn't mentioned in the HOWTO.TXT?

Attachments (1)

complib_error.png (6.8 KB) - added by ataylor 13 months ago.
Error popup shown when adding a component

Download all attachments as: .zip

Change History (6)

Changed 13 months ago by ataylor

Attachment: complib_error.png added

Error popup shown when adding a component

comment:1 Changed 13 months ago by ataylor

OK, it seems that the error messages is kind of a red herring. I'm guessing that it's failing to reload complib.dll after building it somehow. Closing the project and re-opening it turns out to get past that error.

I can add the remaining missing classes by repeating this in sequence: add component, get error message, close Sibyl, re-open, open NewView.spr again. I have eventually managed to get past all the errors and the project opens cleanly.

I notice that it's also necessary to create the directory p:\newview_dev\build\newview in order for run or make to work, but once that's done I seem to be getting a clean build.

I'd suggest this be incorporated into documentation updates.

comment:2 Changed 13 months ago by ataylor

Priority: criticalmajor
Type: defecttask

comment:3 Changed 12 months ago by ataylor

FWIW, it seems the source of the problem is that a version of COMPLIB.DLL with the updated classes in it needs to be available for the IDE to load a project that uses them... and the Components project includes a test form with those classes, so you can't actually build COMPLIB.DLL without already having COMPLIB.DLL available.

It also seems the various paths to COMPLIB.DLL in the project files need to point to the build directory, and not the Sibyl program directory... the instructions in HOWTO.TXT are not very clear about that.

In light of this, I'm now working on an overhaul of the repository's build setup infrastructure and instructions, which will also obviate the need to map to p:\newview_dev with NetDrive?. I'm testing a preliminary version of this now.

comment:4 Changed 11 months ago by ataylor

The revamped build infrastructure is now in place in trunk (revision 413).

(I copied the existing trunk to the pre_reorg branch first.)

comment:5 Changed 11 months ago by ataylor

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.