Opened 2 years ago

Closed 2 years ago

#23 closed defect (fixed)

Default values were not written to NEPMD.INI

Reported by: aschn Owned by: aschn
Priority: minor Milestone: 2.0 beta
Component: Installation Version: 1.16
Keywords: Cc:

Description (last modified by aschn)

After installation of NEPMD the EPM doesn't start with NEPMD settings. In contrast, the NEPMD program object 'Standard EPM' starts.

Renaming myepmd\bin\NEPMD.INI is a workaround for that. A new one is created on the next EPM start. The malfunctioning NEPMD.INI contains the entry:

RegDefaults -> \NEPMD\User\MovedUserFiles

while the correct temporary entry would be:

Install -> \NEPMD\User\MovedUserFiles

That explains why the RegDefaults? application wasn't written. It already contains (wrong) data. As a result, EPM won't start.

Additionally, that temporary entry is normally only written if the install script has copied previous files to a backup directory. The backup directory exists with the files etke603.dll and copydll.cmd. Normally they were deleted afterwards.

It seems as if patching etke603.dll to apply the NEPMD colors has failed at the end.

Change History (5)

comment:1 Changed 2 years ago by aschn

  • Component changed from Other to Installation
  • Description modified (diff)
  • Milestone changed from Unsorted to 2.0 beta
  • Owner set to aschn
  • Status changed from new to accepted

comment:2 Changed 2 years ago by aschn

  • Priority changed from major to minor

I can't reproduce the wrong ini file writing. But the deletion of the temporary files should be fixed. Also another path than myepm\tmp may be suited better.

comment:3 Changed 2 years ago by aschn

One side effect of the missing default values in RegDefaults? is that EPM doesn't start anymore. It has turned out that only color and font settings are critical.

On initialization, it will now be checked if the query function returns a value. If not, fallback values were applied. That makes the EPM window come up, even in that case.

Partly fixed by r2716. A fix for writing new default values in the case of this bug report will follow.

comment:4 Changed 2 years ago by aschn

  • Summary changed from Installation on a faster system: Wrong REXX SysIni write process can lead to malfunctioning NEPMD.INI to Default values were not written to NEPMD.INI

comment:5 Changed 2 years ago by aschn

  • Resolution set to fixed
  • Status changed from accepted to closed

It turns out that ini settings went out of sync between files.

Additionally, the logic to submit info from an installation command to the E macros for the first start had a side effect: Because RegDefaults? still exists, DEFAULTS.DAT/DEFAULTS.CFG was not imported.

The fix includes the setting of default 'emergency' values for ini key queries, even when RegDefaults? is missing. Now the EPM window opens in that case, but only partly initialized. Nevertheless most functions work, also the Save command.

Moreover, the user is now notified about the error and gets the option to work around that.

The fix is mainly contained in r2716 and r2727.

The patching of ETKE603.DLL still has to be reworked and the path logic should be changed, e.g. to use MYEPM\DLL for it instead of replacing the original one. Since there is no real negative impact, I'll close this bug.

Note: See TracTickets for help on using tickets.