#363 closed defect (fixed)

Lucide 1.4.1 beta14 renders pdf as blank pages - regression

Reported by: Steven Levine Owned by:
Priority: major Milestone: 1.4.1
Component: Plugin: PDF Version: 1.4.1
Keywords: Cc:

Description (last modified by Steven Levine)

Lucide 1.4.1 beta14 renders the pdf at

http://home.earthlink.net/~steve53/files/0sprouts.pdf

as blank pages. Lucide 1.4 GA renders the document slowly, but correctly.

Change History (10)

comment:1 Changed 18 months ago by Steven Levine

Component: BackendPlugin: PDF
Description: modified (diff)

comment:2 Changed 18 months ago by Gregg Young

It renders as a blank page in QPDFView with the latest Poppler also. It appears to be a regression in Poppler. I tried the 1.41 beta 5 with the same results.

Last edited 18 months ago by Gregg Young (previous) (diff)

comment:3 Changed 17 months ago by Silvan Scherrer

Greg did you test with your thread changed poppler? not the most recent one. The one you built interim. Just to be sure it's not this change.

Last edited 17 months ago by Silvan Scherrer (previous) (diff)

comment:4 Changed 17 months ago by Gregg Young

I tried it with the patched popple66.dll and it renders slowly but correctly.

comment:5 Changed 17 months ago by Silvan Scherrer

I will update poppler one more time to the last possible version. Which is 0.61. Later versions removed qt4 backend. So not an option for now.

comment:6 Changed 17 months ago by Gregg Young

Hopefully, that will solve the problem. It appears the pages that fail to render are images. The file linked to this ticket doesn't have any fonts. Thanks

comment:7 Changed 17 months ago by Gregg Young

Just thinking out loud. Is it possible one of the image format libs didn't get compiled in?

comment:8 Changed 17 months ago by Silvan Scherrer

We lost the JPXDecoder, because they have the internal one marked as depreciated and it needs to be enabled with a switch. I build 0.59 with this switch as of now. lets see then.

comment:9 Changed 17 months ago by Gregg Young

I got the new 0.59.0. It works with the sample pdf in this ticket and also fixed a pdf I have which had the same problem.

comment:10 Changed 17 months ago by Silvan Scherrer

Resolution: fixed
Status: newclosed

fixed with latest poppler from exp repo. Btw please let me know when you plan to create the GA. So I can move poppler some days in advance to rel repo.

Note: See TracTickets for help on using tickets.