Opened 14 months ago

Closed 8 months ago

#355 closed defect (fixed)

Lucide 1.40 GA - crashes with large PDF files

Reported by: darcio Owned by: gyoung
Priority: major Milestone: 1.4.0
Component: Backend Version: 1.4.0
Keywords: large pdf file causes crash Cc: steve53@…

Description

Lucide has been a pretty reliable PDF viewer for the most part, always displaying PDFs correctly but having some problems with printing. For the big print jobs I have been using GSView instead.

Recently I started work on Python programming and needed to review some PDF books. These are fairly large, some 25Meg in size. Attempting to open them (tried several) produce a crash. No error entry is present in popuplog.os2 though, nothing in the trap location either.

The Lucide 'Plugin list' shows lupplr (PDF plugin, based on poppler library 0.52.0) as the PDF plug-in. Since I have a YUM/RPM 'pentium4' platform install here I have the following pre-requisite modules installed:

libc.i686 (0.6.6-35.oc00)
libgcc1.pentium4 (4.9.2.1-3.oc00)
libgcc-fwd.pentium4 (4.9.2.1-3.oc00)
libstdc++6.pentium4 (4.9.2.1-3.oc00)
libsupc++6.pentium4 (4.9.2.1-3.oc00)
poppler.pentium4 (0.52.0-1.oc00)
poppler-data.noarch (0.4.7-2.oc00)
djvulibre.pentium4 (3.5.27-3.oc00)
uclip.pentium4 (0.3.0-1.oc00)
GBMDLL.i686 (1.76-1.oc00)

...but I do not have the libjpeg package, instead I am using: libjpeg-turbo.pentium4 (1.5.1-1.oc00).

I am guessing the large PDF filesize is causing a problem. To hopefully simply the troubleshooting I will u/l one of the PDF files, assuming I can get something that large attached to the ticket.

Change History (10)

comment:1 Changed 14 months ago by darcio

Nope...waaaaay too big for the 250KB limit...OK, here is another stab at this.

I have the zipped file listed on my web server, please get it from: http://darcio.no-ip.org/os2/lucide-ticket355-large_pdf_file.zip

comment:2 Changed 14 months ago by diver

did you eventually try qpdfview as well? Just to see if it also crashes or not

comment:3 Changed 14 months ago by darcio

Yes, these open fine in qpdfview, my only problem with that approach is that qpdfview requires cups for printing which I do not have on my machine since my Brother printer is a PS machine and I imported the PPD file into the IBM PS driver, in short, it works for me as-is and I did not want to introduce another layer of complexity.

So, since I can not print from qpdfview my only alternative is Ghostscript or Lucide, this is the reason why I'm hoping we can get Lucide working with these big PDF files.

Also, for what it's worth, Lucide is simply much faster then qpdfview with it's QT framework overhead.

comment:4 Changed 14 months ago by stevenhl

  • Cc steve53@… added

Take a look at http://trac.netlabs.org/lucide/ticket/350.

It might provide a workaround. The reported issue only affects large pdf files.

comment:5 Changed 13 months ago by darcio

@steve53 Hmm..interesting. OK, I went and tried this...indeed, it worked...the problem is that it's a bit of a "catch-22", meaning: you can enable thumbnails to open it successfully, but then upon the next open attempt Lucide fails because there is a thumbnail created and that causes a failure. At least that was my experience here.

So to make that work I would have to strip out the thumbnail from the document each time I finish looking at it.

comment:6 Changed 13 months ago by stevenhl

Yes, it is a somewhat crude workaround. A proper fix is going to have to wait until one of the maintainers implements a fix. You do have some relatively painless workarounds. Since you know which PDFs cause the traps, you can create a Desktop object that strips the EAs from the problem PDFs.

This issue is on my list to look at along with a couple of other items I'd like to see changed, but other tasks keep using up my available time.

comment:7 Changed 11 months ago by gyoung

This doesn't trap here. However, if I load the linked pdf after the thumbnail is added to the eas the table of contents shows in the navigation pane but the actual document isn't shown (pane remains gray). The main pane navigates as if the document is visible (ie if I double click a content entry the vertical scroll bar moves to a new location).

If I render the first page as is done by createThumbnail it all appears to work correctly. I simply render it then delete the buffer holding it.

comment:8 Changed 10 months ago by gyoung

  • Owner set to gyoung
  • Status changed from new to assigned

The problem is caused by Poppler exhausting OS2's mutex handles. I finally managed to get Poppler to build and have fixed the mutex issue. There was also an issue with the code in Lucide that loads the files. Also fixed. The 7z file is too big to upload here. I can upload it to Netlabs incoming or send it directly to you. It includes the Poppler dll so to test just unzip it; make sure the first thing in your libpath is "." and run it. If you want me to send it directly email me at ygk at qwest dot net.

comment:9 Changed 9 months ago by darcio

@gyound - Gregg, big PDFs...yey, I think this issue is addressed, the file I had previously ran into problems with is fine now, no crash but thumbnails do not show, so maybe I'm missing something simple (I provided the same update on the AOS Testers List (FYI), also sorry I missed your update here from nearly two weeks ago...is there a way to turn ON a notification email so I know when the ticket is updated in the future?

comment:10 Changed 8 months ago by gyoung

  • Resolution set to fixed
  • Status changed from assigned to closed

This trap was fixed in poppler. Will need to update Lucide to poppler 0.59.0 to get the fix.

Note: See TracTickets for help on using tickets.